The platform "35729" does not appear to have been added to this project

Hi guys,

I’ve just updated my Ionic CLI by doing

npm install -g ionic

And now I can’t run my app anymore by doing

ionic cordova run android --verbose

It returns this error

No scripts found for hook "before_run".
No scripts found for hook "before_prepare".
Checking config.xml and package.json for saved platforms that haven't been added to the project
Config.xml and package.json platforms are the same. No pkg.json modification.
Package.json and config.xml platforms are different. Updating config.xml with most current list of platforms.
PlatformApi successfully found for platform android
Android Studio project detected
The platform "35729" does not appear to have been added to this project.
Error: The platform "35729" does not appear to have been added to this project.
    at Object.getPlatformApi (C:\Users\Adam Gelineau\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\platforms\platforms.js:46:15)
    at C:\Users\Adam Gelineau\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\prepare.js:53:38
    at Array.map (<anonymous>)
    at C:\Users\Adam Gelineau\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib\src\cordova\prepare.js:51:47
    at _fulfilled (C:\Users\Adam Gelineau\AppData\Roaming\npm\node_modules\cordova\node_modules\q\q.js:854:54)
    at C:\Users\Adam Gelineau\AppData\Roaming\npm\node_modules\cordova\node_modules\q\q.js:883:30
    at Promise.promise.promiseDispatch (C:\Users\Adam Gelineau\AppData\Roaming\npm\node_modules\cordova\node_modules\q\q.js:816:13)
    at C:\Users\Adam Gelineau\AppData\Roaming\npm\node_modules\cordova\node_modules\q\q.js:624:44
    at runSingle (C:\Users\Adam Gelineau\AppData\Roaming\npm\node_modules\cordova\node_modules\q\q.js:137:13)
    at flush (C:\Users\Adam Gelineau\AppData\Roaming\npm\node_modules\cordova\node_modules\q\q.js:125:13)

I don’t know what to do here, I don’t know what is “35729” platform…

Thanks :slight_smile:

EDIT 1:
Downgraded to 4.9.0 resolved the issue, how can we report that problem to the Ionic Team ?

9 Likes

You made my day :smiley:. I upgraded from ionic 4.9.0 to 4.10.0 over the night and everything seemed to work fine after a few tests. Today I completely de- and re-installed nodejs (I know some kind of stupid action to drive myself crazy :sweat_smile:) and I was searching everywhere for the last 3 hours. Thanks a lot!

1 Like

You’re welcome ^^ I don’t know what happened with this new version though

faced same issue, after downgrade, its working fine now. Thanks

hi AdamGelineau
thi error " Since ionic cli 4.10.0 | TypeError: arg.includes is not a function" was corrected in ionic cli 4.10.1

4 Likes

Pretty fast update :hushed:. Thanks a lot :wink:

After downgrading started working. Tried upgrading node as well, but didn’t seems to be working with latest version of ionic.

Hello,
You talking about downgraded the version of Gradle ? How to make that ?
Thanks!

if you are working on mac osx, you can do it with homebrew (= package manager), e.g.:

brew update
brew install gradle
brew search gradle
brew switch gradle 4.8

P.S.: But it works for me with latest version - gradle 5.1.1

Hello,
And for Windows?

Just run this and this error shouldn’t appear anymore. 4.10.0 had an error but now if you run it you’ll have 4.10.1 version. Just check that up :wink:

thanks a lot !!!

Perfect. I solved this issue once I update ionic version from 4.10.0 to 4.10.1
Thanks :smile:

1 Like