Can't add android platform to a new ionic project

I’m starting a new Ionic project and I initialised it:
ionic start myApp blank

then I tried adding the android platform:
ionic platform add android

and got the following error message:
`Updated the hooks directory to have execute permissions
Downloading Default Ionic Resources
[=============================] 100% 0.0s
Done adding default Ionic resources
Adding icons for platform: android
throw err;

Error: Cannot find module 'elementtree’
at Function.Module._resolveFilename (module.js:327:15)
at Function.Module._load (module.js:278:25)
at Module.require (module.js:355:17)
at require (internal/module.js:13:17)
at Object. (/usr/local/lib/node_modules/cordova/node_modules/cordova-lib/src/configparser/ConfigParser.js:22:10)
at Module._compile (module.js:399:26)
at Object.Module._extensions…js (module.js:406:10)
at Module.load (module.js:345:32)
at Function.Module._load (module.js:302:12)`

what am i missing?

I’m working on an existing project. I removed the platform and re-added it and start getting same issue.

I don’t see a stack trace like yours … It just says: Error: Cannot find module 'elementtree'

EDIT: For me it turned out that I had an additional hook from a plugin that didn’t install elementtree.

EDIT 2: I ran the same commands that you ran… I wasn’t able to reproduce the issue. Try running npm install -g elementtree

I removed ionic from npm and reinstalled and no longer getting it. But still can’t start an ionic project. I think getting started page is missing some serious setup and prerequisites instruction. And not at all updated.