Testing default ionic app on ios emulator

Hi all,

Recently purchased a mac and started doing some development with ionic. I have installed xcode and ios-sim.

When I build and try to emulate the default tabs ionic app, the emulator just displays a black screen.

Does anyone know what could be causing this? Am I missing some necessary libraries?

Any help is greatly appreciated.

Do you ever see the Apple logo when the simulator is booting up? If not then something’s wrong with your simulator.

Hi iarry,

When I run ios-sim start, the emulator loads fine.

Its when I try to run it using an ionic app. I do not even see the apple logo when I run the simulator for an ionic app.

Any ideas?

Run ionic platform add ios and ionic build ios. Then open the Xcode project in the myApp/platforms/ios folder (make sure the Xcode project has the same name as your project, sometimes I need to run ionic build ios twice the first time around for an app). Running it through the simulator via Xcode with the play button in the top left.

Hi iarry,

Thanks for the help. I figured out what my issue was. I was running the emulator using sudo as if I ran it without sudo I was having permission issues.

After I ran ‘sudo chown -R $(whoami) ~/Desktop/myproject’ it solved my issue and the emulator is now working as expected.

Thanks again.