Suddenly cannot build for ios


#1

I’m getting below error when building for ios. Not sure why… but seems the .xcodeproj name is repeated twice.

[localhost] local: ionic build ios
Running build task…
Building platform ios
Running command: /Users/young/Projects/mobile/myproject/platforms/ios/cordova/build
Build settings from command line:
    ARCHS = i386
    CONFIGURATION_BUILD_DIR = /Users/young/Projects/mobile/myproject/platforms/ios/build/emulator
    SDKROOT = iphonesimulator7.1
    VALID_ARCHS = i386

xcodebuild: error: ‘MyProject.xcodeproj.xcodeproj’ does not exist.
Error: /Users/young/Projects/mobile/myproject/platforms/ios/cordova/build: Command failed with exit code 66
    at ChildProcess.whenDone (/usr/local/lib/node_modules/cordova/src/superspawn.js:126:23)
    at ChildProcess.EventEmitter.emit (events.js:98:17)
    at maybeClose (child_process.js:743:16)
    at Process.ChildProcess._handle.onexit (child_process.js:810:5)
ERROR: Unable to build app on platform ios. Please see console for more info.
Exiting.

Fatal error: local() encountered an error (return code 1) while executing ‘ionic build ios’

Aborting.


#2

Hmm, can you try cordova build ios?


#3

Yes. I just tried, but failed and giving me the same message.
Is there a configuration file to change MyProject.xcodeproj.xcodeproj to MyProject.xcodeproj ?


#4

This seems not only my problem: http://stackoverflow.com/questions/20915395/phonegap-build-ios-exception-with-helloworld-application


#5

Hmm, interesting…
Does the solution solve your issue?


#6

Yes. Just followed the recommended answer and worked. :slight_smile: if any of you are having the same issue, please follow the stackoverflow link attached from my above comments.