$State.go problem in real device


#1

How to fix if the $state.go im real device not run but if im using browser base its ok. thanks


#2

what exactly is your code? can you show it in order for others to understand what was your problem all about or error in your code…


#3


the process is true. $state.go(‘app.frmdashboard’);


#4

maybe your using it outside a controller so that’s why it doesn’t works. maybe you can use $location.path('/url_of_page');


#5

same error sir , but the other $state.go(‘app.frmdashboard’); are working in my function how about my login , what the specific problem hmmmm.


#6

The problem if the application is in real device. but if web view its ok.


#7

maybe your routing config is messed up…


#8


This is my routing


#9

where is the frmsetup route here?


#10

Solved this problem thank you :slight_smile:


#11

please mark it solved and post/discuss how you solve it in order for others that having the same problem to have an idea what is the cause of the problem and how to fix the said problem…


#12

i solved my problem once i attempt to use third party application to show the debug from real device to google chrome inspect mobile. my problem are the first controller is a encounter a error then after can see the error can fix that then ok :slight_smile: