[Solved] Popup not showing on phones?


#1

I have a popup that works fine when using ionic serve in the browser, but as soon as I build and run it on both android and ios, the popup does not even show when being called. Everything else seems to work as intended in the app.

Code for my popup:

$scope.showPopup = function() {
   
 
   $scope.data = {}
   // A popup
   var myPopup = $ionicPopup.show({

     template: '<input type="password" ng-model="data.code">',
     title: 'Enter your code',
     subTitle: 'This can be found in the email sent to you',
     scope: $scope,
     buttons: [
      // Button names 
       { text: 'I don\'t have a code',
         onTap: function(e, response) {
         <stuff happens>
        }

      },
       {
         text: 'Enter',
         type: 'button-positive',
         //When the enter button is pressed, call function
         onTap: function(e, response) {
        <other stuff happens>
         }
       },
     ]});

  };

And then it’s called from a tab being clicked:

 <ion-tab title="Day Schedule" icon="ion-calendar" ng-click="selectTabWithIndex(1); showPopup()">
			<ion-content class="tabcontent" scroll="true">
            <stuff>
			</ion-content>
        </ion-tab>

Any ideas?

Edit: As usual, as soon as you post something it begins to work again. Incredibly weird but hey it works!


Popup not showing on phones
#2

Hey there. You should still remote debug and see if there are any errors coming up


#3

I have the same problem but there are no errors. The problem appears on Android device but that’s works in emulator and browser. I don’t need debug. When the popup appears, I saw it few milliseconds then the popup go out of the screen. I can just saw the backdrop and I’m blocked because I can’t close the popup.

How is possible ? I’m alone with this problem ?


#4

Can you provide a codepen or plunker, I can test it on a device and see what the issue could be.

Also, are you testing with the nightly builds?


#5

I did nothing more than your exemple : http://codepen.io/ionic/pen/zkmhJ
I tried with v1.0.0-beta.10 and v1.0.0-beta.10-nightly-309 and the result is the same.

I just tried to test this codepen from the tablet browser and the popup does not appear.


#6

Hmm, just ran this on a 4.2 and the popups are showing. Any information as to what device you were testing on?


#7

It’s on a Samsung galaxy tab 2.

It’s not my tablet so I didn’t want to install the google chrome app and I used the default browser.

Once built, is the android app using webview using the default installed browser to show the app ? I don’t know if an android app has his own engine to show webview but the problem can be there.


#8

Anything under android 4.4 uses the default webview, that is a non-chrome webview.

If you have issues with the older webview, this could help you out. It’s basically the chrome webview for cordova.


#9

Ok thank you for your help. I will try