[SOLVED] Ionic run doesn't work but Xcode run works (live reload problem)


#1

ionic build iOS = success

If I open then Xcode and run my project, the debugger start and my app load, everything’s fine, like a charm, cool

If instead of using Xcode, I want to run, after building it, my app with the command “ionic run ios -l -c”, the iOS debugger start but my app doesn’t load. I’ll then see an endless spinner loading for ever

Any clue?

ioni info for the record:

Your system information:

Cordova CLI: 6.1.1
Gulp version: CLI version 3.9.1
Gulp local:
Ionic Version: 1.2.4
Ionic CLI Version: 1.7.14
Ionic App Lib Version: 0.7.0
ios-deploy version: 1.8.6
ios-sim version: 5.0.8
OS: Mac OS X El Capitan
Node Version: v5.3.0
Xcode version: Xcode 7.3 Build version 7D175


#2

Ok then I dig deeper and seems that the problem isn’t a difference between Xcode or whatever but the live reload itself

ionic run ios => success

ionic run ios -l => hang on a splash screen

even

ionic run ios --target=“iPhone-6, 9.1” -c -s => success

Did someone also faced a problem with live reload?


#3

Ok I found my problem. Solved it like following:

  1. cordova plugin add cordova-plugin-whitelist

  2. In my config.xml, added < allow-navigation href=“http://localhost*”/ >

  3. Just to be sure, enhanced my run command with -address localhost, like

ionic run ios --target=“iPhone-6, 9.1” -c -s -l --address localhost