[Solved] Application Error - Ionic


#1

Hello people,

I’m having an error when i run my app on device.
In pc browsers works ok, but on android device after launch the app, i have this error:

With $ionic run android --consolelogs --livereload:

Application Error
net::ERR_CACHE_MISS(http://192.168.120.54:8000/)

If i run:
$cordova build android
$cordova run android

The app runs, but when i want to login with firebase, i have this error:

Error: A network error (such as timeout, interrupted connection or unreachable host) has occurred.

Before, the app worked fine, this started to happen when i installed this plugin: https://ionicframework.com/docs/v2/native/firebase/

But it did not work, it was saying something like this: “ionic-native have no exported member called Firebase” when running the app in the pc browser.
Then I ran again:
$ Ionic run android
$ Cordova build android
$ Cordova run android

And it did not work.
Opt to delete the plugin and continue with other things to not waste time …

And now I find the problem I mentioned at the beginning of the post. I think the firebase plugin changed something that generates the broken builds.

Any idea? Anything that can help me will be grateful.

Thank’s in advance!


#2

If anyone have the same issue, i just solved it thanks to @shashikiran797 in this thread:


#3

when i try to logout from the application it shows this error…I pasted your code in AndroidManifest.xml but still there is an error? any other solution ?


#4

It does not work for me…I am still getting the same error…network error,connection timed out…


#5

Hey @vithika @Colo9311 @shashikiran797 , actually I am having the same issue with my app, it is giving me 502 Connection timed out error on making an api call and this is only happening on using Jio Network. I really don’t know what causing this problem because app works fine on other networks, but Jio network causing the problem.
Can you help me with it?


#6

Try adding this to your config.xml

<access origin = "*" />


#7

Hey, I added it, but still getting the same error only on Jio Network.


#8

did you try accessing the same api through any other rest clients like Postman on jio network?

and try accessing some public apis on your application on jio network and see if it works


#9

Hey,

Thank you so much for your help, I got the bug which was causing the problem.

Thanks again :slight_smile:


#10

What was causing the bug?


#11

Sorry for late reply, but my problem was that my app didn’t know that the domain it is trying to hit is whitelist or not? So, I came to know about a plugin called :
cordova-plugin-whitelist

(Actually, by default it is included in every ionic project but I think the version which was in my app was old, so by installing it again, I got the latest version.)

Then I added this in my app and also made the subdomain available, and it worked for me.
Thanks :slight_smile: