[solved] Aapt.exe finished with non-zero exit value 1


#1

I cannot build an android solution now. Any clue what this is about?!

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':processDebugResources'.
> com.android.ide.common.process.ProcessException: org.gradle.process.internal.ExecException: Process 'command 'C:\Users\dylan\AppData\Local\Android\android-sdk\build-tools\23.0.3\aapt.exe'' finished with non-zero exit value 1

BUILD FAILED

Total time: 15.795 secs

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output.
Error: Error code 1 for command: cmd with args: /s,/c,"y:\Projects\GraduateApp\platforms\android\gradlew cdvBuildDebug -b y:\Projects\GraduateApp\platforms\android\build.gradle -Dorg.gradle.daemon=true -Pandroid.useDeprecatedNdk=true"

#2

I’ve reinstalled node, cordova, ionic@beta. Removed and readded the platform. Running out of ideas!


#3

Was an issue with plugins. Removed a bunch and reinstalled and everything builds again.


#4

In my case the problem was, that there were filenames in my assets folder that had invalid characters.

  • Filenames can’t be too long.

  • äöüß… don’t seem to be allowed

  • Spaces seem to be allowed (!)

Also, after making changes to the filenames in src/assets, search your project for assets folder, and delete all it’s content (except for the main asset folder src/assets), because these are not cleaned when you recompile!!!

After changing these filenames (and deleting the files with invalid names in the other (cached) folders (android,…)), the build worked again!!