Slides don't slide for android in ionic serve --lab

#1

the slide mechanism works for ios and windows, but not for android.

I updated ionic 2 to 2.0.0. any ideas?

1 Like
#2

Without using the lab switch, what happens when you do the following…?

Windows > Chrome > Right-click (or Control + Shift + I) > Inspect > Control + Shift + M > (Choose an Android phone from the dropdown)

Mac > Chrome > Right-click (or Command + Alt + I) > Inspect > Command + Alt + M > (Choose an Android phone from the dropdown)

“-l” or “-lab” isn’t perfect. I’ve found using Chrome’s simulator is better.

1 Like
#3

that’s very interesting, I didn’t know Chrome could do that. (and it’s cmd + alt + I to inspect on mac)

unfortunately, ion-slides didn’t work on any of chrome’s simulated devices.

#4

Oh boy, that’s really bad news.

Do the following to see it live on your phone…

  1. to get the Mac’s IP address, Apple > System Preferences > Network (the IP will be listed on this screen)

  2. to share the locally served Ionic app, Apple > System Preferences > Sharing > (check the “Internet Sharing” service to ON)

  3. open the phone’s browser to the IP address, port is usually 8100 (example: http://192.168.228.179:8100)

1 Like
#5

I got it to load on my iphone using ionic serve --all, and yeah, it works on my iphone.

couldn’t get it to load in my android tablet’s browser. the ionic view app won’t load on it, either. not sure why, it could be because it’s a tablet or because it’s an old tablet.

I created a new ionic2 project and added the following to home.html:

<ion-content padding>
  <ion-slides>
    <ion-slide>test 1</ion-slide>
    <ion-slide>test 2</ion-slide>
    <ion-slide>test 3</ion-slide>
  </ion-slides>
</ion-content>

same result. doesn’t work in chrome simulator nor android for ionic serve -l.

#6

wow, I just noticed that slides don’t work for the android example in the documentation. can someone confirm this?

#7

That scared me for a second. It’s just a bug in their example.

Slides do work in Android devices. I just verified on one of my programs.

#8

hmm… well it’s a bug that exactly reflects the issue I’m having. what’s your ionic info? here’s mine

    Your system information:

    Cordova CLI: 6.5.0
    Ionic Framework Version: 2.0.0
    Ionic CLI Version: 2.2.1
    Ionic App Lib Version: 2.2.0
    Ionic App Scripts Version: 1.0.0
    ios-deploy version: 1.9.0
    ios-sim version: 5.0.13
    OS: macOS Sierra
    Node Version: v7.2.1
    Xcode version: Xcode 8.2.1 Build version 8C1002
#9
Cordova CLI: 6.4.0 
Ionic Framework Version: 2.0.0
Ionic CLI Version: 2.2.1
Ionic App Lib Version: 2.2.0
Ionic App Scripts Version: 1.0.0
ios-deploy version: 1.9.0 
ios-sim version: 5.0.13 
OS: macOS Sierra
Node Version: v7.4.0
Xcode version: Xcode 7.3 Build version 7D175
1 Like
#10

FML. thanks for your help. appreciate it.

#11

Is there any news on this? Did you fix it, appgod?
I can confirm this issue. It happens in my local build and in the documentation as stated above.