Set minimum required iOS version

Currently my Ionic project is using “Ionic 1.1.0”, and I am just building my app fo iOS as of now. The XCode project that is built by Ionic has deployment target set for 6.0. Now when I build IPA for my project and distribute through Test Flight, in “Compatibility section” it says “Compatible with iOS 6 and later”. However, we only intend to support iOS 8 and above.

I know I can update the deployment target through XCode project created, however, I want to update this in my Ionic project, but, this won’t work for me, because whole process is automated and I want to be able to control this from Ionic.

Is it possible? I don’t any thing in config.xml that is specifying the minimum required iOS version, like we do for Android.

Please let me know if it is possible, and if possible how can I do that.


Not sure it works for Cordova but in this discussion on the phonegap GitHub they seem to say you can use

<preference name="deployment-target" value="7.0" />

Thanks for your response, I already did this with cordova hook. But this is a shorter version.


@ravishtiwari Sorry to bump an old topic but I was wondering if you could share how you solved this problem in the end? I’m looking to set the minimum required iOS version for my app to 9.3.1, which is the lowest one I’ve tested my app on. I’ve tried using the deployment-target preference but it does not seem to have any effect when using Ionic Cloud to build. Is this easily done with a hook as you described?

Hi @marcusforsberg deployment target worked for me, but, I just put this under , like:

<platform name="ios">
<preference name="deployment-target" value="8.0"/>

Earlier I was using a hook, however, this is working for me.

1 Like