Real-Time Update NOT working on real iOS device

When I using AppFlow Real-Time Update in Xcode with iOS simulator or connecting with real iOS device, the update works.
However, if disconnected with Xcode, the real iOS device can NOT get the Real-Time Update anymore.
And I am using Capacitor.

from --> Usage this month, it still shows ‘0 USED’, and no deploy history there.
Whether the Real-Time Update only works on the package build made by AppFlow? I am testing with the app build by Xcode only.
Any idea?

Thanks in advance.

Hey @agileact-admin, did you get more info on this? I’m also wondering if realtime updates only work when the package was made by AppFlow…

I’ve packaged some .IPAs with Xcode and they doesn’t seem to get any updates. I don’t know if this is due a misconfigured update channel or what. I’ve tried to find the plugin update channel configuration CHANNEL_NAME on my Xcode project to check this, but I had no luck (I was expecting to find the channel configuration on other files beside config.xml and package.json).


Same here, I tried every single possible configuration in my Ionic v3 app and nothing worked. I’m not ready to upgrade my app to Ionic 4 yet and if AppFlow works with that version probably I will do it, but for now I’ll stick with the old v3. Quite frustrating though.

  • Ionic:

    Ionic CLI : 5.0.2 (/usr/local/lib/node_modules/ionic)
    Ionic Framework : ionic-angular 3.9.5
    @ionic/app-scripts : 3.2.2

  • Cordova:

    Cordova CLI : 9.0.0 (cordova-lib@9.0.1)
    Cordova Platforms : android 7.1.4, ios 5.0.1
    Cordova Plugins : cordova-plugin-ionic 4.0.1, cordova-plugin-ionic 5.4.5, cordova-plugin-ionic-keyboard 2.1.3, cordova-plugin-ionic-webview 1.2.1, cordova-plugin-ionic-webview 2.5.2, (and 10 other plugins)

  • Utility:

    cordova-res : 0.6.0
    native-run : 0.2.9