RC4: Error: No provider for CompilerFactory!


#1

Hi,
I updated from RC3 to RC4. I first had errors with app-scripts but after correcting those, I get the following error in browser (after ionic serve):

Error: No provider for CompilerFactory!

What can be the cause ?
My package.json is the following:

{
  "dependencies": {
    "@angular/common": "2.2.1",
    "@angular/compiler": "2.2.1",
    "@angular/compiler-cli": "2.2.1",
    "@angular/core": "2.2.1",
    "@angular/forms": "2.2.1",
    "@angular/http": "2.2.1",
    "@angular/platform-browser": "2.2.1",
    "@angular/platform-browser-dynamic": "2.2.1",
    "@angular/platform-server": "2.2.1",
    "@ionic/storage": "1.1.6",
    "@types/leaflet": "^0.7.28",
    "angular2-clipboard": "^0.2.12",
    "angular2-jwt": "^0.1.25",
    "angular2-moment": "^1.0.0-beta.3",
    "branch-sdk": "^2.12.0",
    "buffer": "^5.0.0",
    "ionic-angular": "2.0.0-rc.4",
    "ionic-native": "^2.2.11",
    "ionicons": "^3.0.0",
    "js-base64": "^2.1.9",
    "leaflet": "^0.7.7",
    "moment": "^2.15.1",
    "ng2-facebook": "0.0.3",
    "ng2-facebook-sdk": "^1.0.0",
    "reflect-metadata": "^0.1.8",
    "rxjs": "5.0.0-beta.12",
    "typescript": "^2.0.9",
    "zone.js": "^0.6.26"
  },
  "devDependencies": {
    "@ionic/app-scripts": "^0.0.47",
    "browserify-istanbul": "^2.0.0",
    "buffer": "^5.0.0",
    "codecov.io": "^0.1.6",
    "del": "^2.2.0",
    "gulp": "^3.9.1",
    "gulp-rename": "^1.2.2",
    "gulp-tslint": "^6.0.2",
    "gulp-typescript": "^2.13.6",
    "gulp-watch": "^4.3.5",
    "ionic-gulp-browserify-typescript": "^1.0.1",
    "ionic-gulp-fonts-copy": "^1.0.0",
    "ionic-gulp-html-copy": "^1.0.0",
    "ionic-gulp-sass-build": "^1.0.0",
    "ionic-gulp-scripts-copy": "^2.0.0",
    "isparta": "^4.0.0",
    "jasmine-core": "^2.4.1",
    "js-base64": "^2.1.9",
    "karma": "^1.2.0",
    "karma-browserify": "^5.1.0",
    "karma-chrome-launcher": "^2.0.0",
    "karma-coverage": "^1.1.1",
    "karma-jasmine": "^1.0.2",
    "karma-mocha-reporter": "^2.1.0",
    "karma-phantomjs-launcher": "^1.0.1",
    "mkpath": "^1.0.0",
    "phantomjs-prebuilt": "^2.1.12",
    "run-sequence": "^1.1.5",
    "traceur": "0.0.111",
    "ts-node": "^1.3.0",
    "tsify": "^1.0.3",
    "tslint": "^3.14.0",
    "typescript": "^2.0.9"
  },
...
}

Thanks a lot,

Gp2mv3