No provider for Token Platform Pipes

Hi,

I’ve a litle problem…and i don’t know why :’(

Uncaught No provider for Token Platform Pipes! (CompilerConfig -> Token Platform Pipes), http://localhost:8100/build/js/app.bundle.js

Exception catch :
app.bundle.js:32685 Uncaught No provider for Token Platform Pipes! (CompilerConfig -> Token Platform Pipes)ReflectiveInjector_.instantiate @ app.bundle.js:32685ReflectiveInjector.instantiateProvider @ app.bundle.js:32632ReflectiveInjector.new @ app.bundle.js:32621ReflectiveInjectorDynamicStrategy.getObjByKeyId @ app.bundle.js:32273ReflectiveInjector.getByKeyDefault @ app.bundle.js:32801ReflectiveInjector.getByKey @ app.bundle.js:32773ReflectiveInjector.get @ app.bundle.js:32582analyzeAppProvidersForDeprecatedConfiguration @ app.bundle.js:10701bootstrap @ app.bundle.js:47574(anonymous function) @ app.bundle.js:80083cssReady @ app.bundle.js:80108(anonymous function) @ app.bundle.js:80113

ionic info
Your system information:
You have been opted out of telemetry. To change this, run: cordova telemetry on.
6.3.0
Ionic Framework Version: 2.0.0-beta.11
Ionic CLI Version: 2.0.0-beta.37
Ionic App Lib Version: 2.0.0-beta.20
OS:
Node Version: v4.4.7

my package.json :

{
“dependencies”: {
"@angular/common": “^2.0.0-rc.4”,
"@angular/compiler": “^2.0.0-rc.4”,
"@angular/core": “^2.0.0-rc.4”,
"@angular/forms": “^0.2.0”,
"@angular/http": “^2.0.0-rc.4”,
"@angular/platform-browser": “^2.0.0-rc.4”,
"@angular/platform-browser-dynamic": “^2.0.0-rc.4”,
“angular2-moment”: “^0.8.2”,
“chart.js”: “^2.2.1”,
“es6-shim”: “^0.35.0”,
“ionic-angular”: “^2.0.0-beta.11”,
“ionic-native”: “^1.3.16”,
“ionicons”: “3.0.0”,
“mime”: “^1.3.4”,
“ng2-charts”: “^1.1.0”,
“ng2-translate”: “^2.4.1”,
“reflect-metadata”: “^0.1.3”,
“rxjs”: “^5.0.0-beta.6”,
“zone.js”: “^0.6.12”
},
“devDependencies”: {
“del”: “2.2.0”,
“gulp”: “3.9.1”,
“gulp-watch”: “4.3.5”,
“ionic-gulp-browserify-typescript”: “2.0.0”,
“ionic-gulp-fonts-copy”: “^1.0.0”,
“ionic-gulp-html-copy”: “^1.0.0”,
“ionic-gulp-sass-build”: “^1.0.0”,
“ionic-gulp-scripts-copy”: “^2.0.0”,
“ionic-gulp-tslint”: “^1.0.0”,
“tslint-ionic-rules”: “^0.0.3”,
“run-sequence”: “1.1.5”
},
“name”: “challengeme-client”,
“description”: “challengeme-client: An Ionic project”,
“cordovaPlugins”: [
“cordova-plugin-device”,
“cordova-plugin-console”,
“cordova-plugin-whitelist”,
“cordova-plugin-splashscreen”,
“cordova-plugin-statusbar”,
“ionic-plugin-keyboard”,
“cordova-plugin-file”,
“cordova-plugin-file-transfer”,
“cordova-plugin-background-mode”
],
“cordovaPlatforms”: []
}

any idea ?

Thx !

Confirm same, had problem with SQLite plugin, reinstalled cordova from 3.6 to 4.0 and got same error at ionic2 proj

do you have the steps to reproduce ?

I had this error when I upgraded to beta 11 because I still had the old angular2 forms module being loaded.
I set up my bootstrap like so:

ionicBootstrap(
	MyApp,
	[
          disableDeprecatedForms(),
          provideForms(),
          MySuperService
	]);

to my provider array at the app level. These functions are imported from the @angular/forms barrel.

Not sure if it’s just a generic error and their are multiple causes, but this was our issue.

Hi,

Thx to share this marcmeans.

But, i test to use disableDeprecatedForms and provideFomrs but unfortunately it does not solve my problem :’(

Another idea ? :smiley:

Having this exact same problem. Not sure what’s wrong.

Found that that the actual installed modules for @angular/common, @angular/compiler etc. were rc5, instead of rc4. That’s because that we’re allowing for patch updates with “^2.0.0-rc.4” in our package json.

Fixed that and installing the packages again. Fingers crossed for this.

Update: Yeah that was it! All the @angular/* packages installed were rc5. Make sure you have installed only rc4 version of all packages. rc5 introduced a new module format which is messing things up.

Ionic 2 beta.11 is supporting angular 2 rc4

but angular is currently rc5, so you have to manually install angular rc4 packages :

npm install --save @angular/common@2.0.0-rc.4 @angular/compiler@2.0.0-rc.4 @angular/core@2.0.0-rc.4 @angular/http@2.0.0-rc.4 @angular/platform-browser@2.0.0-rc.4 @angular/platform-browser-dynamic@2.0.0-rc.4

Fixed that and installing the packages again. Fingers crossed for this.

Also if you are using ng-translate library, do not use latest version as if required angular 2 rc5

step 1: revised as follows
{
“dependencies”: {
@angular/common”: “2.0.0-rc.5”,
@angular/compiler”: “2.0.0-rc.5”,
@angular/core”: “2.0.0-rc.5”,
@angular/forms”: “0.3.0”,
@angular/http”: “2.0.0-rc.5”,
@angular/platform-browser”: “2.0.0-rc.5”,
@angular/platform-browser-dynamic”: “2.0.0-rc.5”,
@angular/http”: “2.0.0-rc.5”,
@angular/forms”: “0.2.0”,
“es6-shim”: “^0.35.0”,
“ionic-angular”: “2.0.0-beta.11”,
“ionic-native”: “1.3.10”,
“ionicons”: “3.0.0”,
“reflect-metadata”: “^0.1.3”,
“rxjs”: “5.0.0-beta.6”,
“zone.js”: “^0.6.12”
},
step 2:
to command line:
cd : C:\you project
npm update

Oh my God
has failed. help me!!!
image