Problem with ionic add ionic-platform-web-client (windows)


#1

Hi,

When running “ionic add ionic-platform-web-client”, I always get:

Failed to find the bower component "ionic-platform-web-client".
Are you sure it exists? (CLI v2.0.0-alpha.25)

I saw that @hitesh436 had the same issue with ionic 1 here . He mentioned that he did something with bower, but not the exact solution.

I thought ionic 2 was not using it anymore, am I right? For sure, I don’t have bower file with my project and did not see any with the conference app.

I really want to try my ionic 2 app with Ionic view app. How can I fix that issue?

Thanks!


#2

So…

The issue that @hitesh436 had was with Ionic V1.

You are right, ionic v2 doesn’t use bower, thats why we have it on NPM as well.
https://www.npmjs.com/package/ionic-platform-web-client


Ionic add ionic-platform-web-client
#3

Also, you don’t need to add it to view your app in the Ionic View app. You can just run ionic upload in the project directory and then access the app from the Ionic View app.


#4

@brandyshea, you are right! Just did ionic upload and saw my app. I was even able to sync it. Though, when running it, it display a white page! Normal?

If not, how can I fix it?

I think I am near the goal…

Thanks


#5

I forgot to add that I am using a Blackberry Q10. It is working just fine with ionic 1. Maybe with Ionic 2, there is issue. I fully understand it is in alpha, but already like it so much! :smile:


#6

Well, BB10 has webkit for a browser, the same that ios has. Though, we’re not going out of our way to support BB since it has such low market share.


#7

Hi @mhartington, not too sure to understand when you talk about “webkit for a browser”. What exactly it implies?

I am not too sure to understand why Ionic 1 was working on BB10 and not Ionic 2 app with Ionic View, but probably too technical to explain for that forum.

But, just to make sure. If I try it on an ios phone, it will work, right?

In the mean time, I will see what I can do with Blackberry Webworks. Again, that tool worked with Ionic 1. I will see if it will be the same for Ionic 2.

Thanks for your answers


#8

Hi @brandyshea,

I asked one of my friend to open the conference app and mine on his iPhone and got the same white page view when opening it from Ionic View.

Like you suggested, I did not add ionic-platform-web-client and did only ionic upload . What exactly you do at your place to make it work? Am I missing something?

Thanks


#9

Does it work when you run ionic serve and view it in the browser?


#10

@brandyshea, yes both code work perfectly with ionic serve.


#11

So does the www/build folder exist before you upload it? Can you try running ionic build and then ionic upload to see if that works? The only way I am able to reproduce the white screen is by removing the build folder.

I went ahead and created an issue for this to build the app prior to upload:

https://github.com/driftyco/ionic2/issues/700


#12

Hi @brandyshea,

The build directory is there with /js/app.bundle.js file, but I think you are expecting more than that, correct?

When doing ionic build, it told me that I don’t have the ios platform installed. It is true, I did not install anything because I am working on Win10. I thought that when doing “ionic upload” the Ionic server was doing the work for me, behind the scene.

With Ionic 1 application, I was able to push my app to the ionic.io platform and use it directly with BB10 without compiling with android. I admit, I’v never tried with Apple phone.

I am going to install the Android SDK and see if it will work with BB10. For the ios, I will probably use the Adobe platform to see how it works.

I guess, you can remove the issue in your system.

Thanks for your help!


#13

Hi @mhartington, even if I use NPM to install ionic-platform-web-client, the ionic add will still generate the bower error:

Failed to find the bower component "ionic-platform-web-client".
Are you sure it exists? (CLI v2.0.0-alpha.25)

#14

@icarus_31 have u solved the problem?


#15

@Beetawix, yesterday, I asked someone who has an iPhone to try my app with Ionic View. He told me that he was able to play with my app successfully!

I tried to install the ionic-platform-web-client with npm i ionic-platform-web-client before doing ionic upload. After, I uninstall it and tried again and it was still working.

I am using alpha45 with the new structure and Typescript:

Your system information:

Cordova CLI: 5.4.1
Gulp version:  CLI version 3.9.0
Gulp local:
Ionic Version: 2.0.0-alpha.45
Ionic CLI Version: 2.0.0-beta.15
Ionic App Lib Version: 2.0.0-beta.8
OS:
Node Version: v4.1.2

#16

@icarus_31 I’ve downgraded the bower’s version from 1.2.4 to 1.1.1 and I solved :slight_smile:


#17

Cool! I don’t have bower installed, but it is good to know


#18

Simple answer, but is your internet working? I got the same error message, then switched my internet and it worked fine.