Problem running IOS


#1

When I use ionic run ios, is always happening this:

and get stuck. It is a new project and ionic cli is updated.


#2

I’ve had this too it seems to still install it on my device and everything works though. For some reason the this didn’t happen the very first time I ran it on my device but every time after that (even after uninstalling) it started happening. It might be a bug with the new cli because I think I updated from beta 9 to beta 11 but I never went back to check if this was the problem.


#3

Well, now that you said, I think it started near the time I updated the cli…


#4

I’ve also been having this issue. I am running iOS 8 beta 5 and Xcode 6 beta 7 but these issues seem to be effecting people using Xcode 5 and iOS 7 as well.

One thing you can do if its hanging on (lldb) is make sure that an old processes isn’t running (which can happen if you do control + c). You can do this by typing

ps -ef | grep lldb

and if some processes are still running do:

killall lldb

This fixes my hangup on (lldb) however it still doesn’t connect

Platform: remote-ios
Connected: no

and hangs here now instead:

(lldb) script fruitstrap_connect_url=“connect://127.0.0.1:12345”
(lldb) command script import “/tmp/fruitstrap_.py”
(lldb) command script add -f fruitstrap_.connect_command connect
(lldb) command script add -s asynchronous -f fruitstrap_.run_command run
(lldb) command script add -s asynchronous -f fruitstrap_.autoexit_command autoexit
(lldb) command script add -s asynchronous -f fruitstrap_.safequit_command safequit
(lldb) connect
Process 0 connected

Doing some research some people have said it “might” be an issue with ios-deploy but I can’t say for sure. I have uninstalled, reinstalled and updated the following:

  • cordova@3.5.0-0.2.7
  • ionic@1.2.0
  • ios-deploy@1.1.0
  • ios-sim@2.0.1

I’d also like to mention that ionic emulate ios works just fine.


#5

It might be something on ionic… Cause on another Sencha project, it doesn’t happens.
Or maybe it’s my device…


#6

It has to do with ios-sim and ios-deploy. ios-deploy has never worked 100% the way it should and has always been problematic.


#7

But why it fails on ionic but works on sencha?


#8

We’re having the same issue. Our build process is always stuck here :frowning:


#9

The same happens to me, but the app is copied to the device. (even live-reload, console and server logs work).