Out of the box Error

So upon creating a new project now and downloading everything it gives the following error when serving:

WARN: No gulpfile found!
If your app requires a build step, you may want to ensure it runs before serve.

And when serve launches the only thing it shows on the platforms is:
Error: ENOENT: no such file or directory, open ‘/home/raz/Work/Ionic/ionic2-tutorial/www/index.html’

The apps i was working on are still working its just the new ones that i pull that are having problems, a coworker of mine on a different OS tried to reproduce the error and got the exact same result.

1 Like

i has similar problem;
see issue

I think it is related to the new release of ionic, which does not use gulp any more.

Just upgraded to 6.6 and it still fails im going to try to install 6.7

i think:

  • for older projects you will need the older ionic cli;
  • for new projects you will need the latest version of ionic cli;
    the reason for this is that the structure of an ionic project changed between ionic beta and ionic rc1(the latest)

updated to 6.7 = not a solution

updated ionic cli using:

sudo npm install -g cordova ionic@beta

And still doesnt work =(

Don’t use the @beta tag, just sudo npm install -g ionic.

Also, if you’re still having issues after updating to 6.7, first try:

npm uninstall -g ionic
npm cache clean

and then try the install command again.

1 Like

you can have multiple versions of node using n:

This worked!

By the way thank for your work Mr Josh been following your awesome documentation for weeks now! keep up the good work!