No gulp file error with fresh project


#1

Going through this blog post trying to get lazy loading set up and having some problems.
I cloned this repo: https://github.com/mhartington/lazyLoadTabs
Ran npm install, then did “ionic serve” and got this error:

WARN: No gulpfile found!
If your app requires a build step, you may want to ensure it runs before serve.

The app opens in the browser and displays…
“Error: ENOENT: no such file or directory, open ‘/Users/XXX//lazyLoadTabs/www/index.html’”

Incidentally, I tried the starter blank tabs app “ionic start XXX tabs” and there’s no typescript files or src directory?? When did that happen?


#2

Hard to say for sure given only the information provided, but I’m going to blindly guess you are reading documentation for the v3 CLI, which defaults to making current Ionic projects, yet actually using the v2 CLI, which defaults to making v1 ones.


Ionic 3.5 with ts
#3

Indeed, when I run ionic info I get this:

Cordova CLI: 6.1.1
Gulp version:  CLI version 3.9.1
Gulp local:  
Ionic Framework Version: 3.0.1
Ionic CLI Version: 2.0.0-beta.31
Ionic App Lib Version: 2.0.0-beta.17
ios-deploy version: Not installed
ios-sim version: Not installed
OS: Mac OS X El Capitan
Node Version: v6.9.0
Xcode version: Xcode 8.3.2 Build version 8E2002

Does that mean I can’t run the linked repo unless I update?
I tried npm uninstall -g ionic and a reinstall and the CLI version did not change. :-/

Edit: also tried npm install-g ionic@beta and the CLI version still is 2.0.0-beta.31… I’m confused now.


#4

No need for @beta. If you have further problems, I highly recommend using nvm to manage your node installation. It makes environment-related problems infinitely easier to fix.


#5

Okay, got things working and apparently the reason I couldn’t update was because I was using versioning (node brew). Apparently I had two concurrent installations of ionic that were conflicting. Anyway, problem resolved, project serves successfully now. Thanks for the tip, it pointed me in the right direction!