On iOS Devices, First Tap is Not Registering, After Closing a Modal Screen or Opening / Closing the Side Menu


#1

Working on an Ionic2 app. Everything works as expected when I run ionic serve , but when I build the app and run in the iOS Simulator or a physical iOS device, I start to get unresponsive taps.

From the main <ion-list>, if I tap an <ion-item> to open a modal, everything works fine. But when I close the modal with this.viewCtrl.dismiss(), the next time I tap an <ion-item> on the main <ion-list>, the tap is not detected.

I added a console.log and can see that the first tap is not detected, then my second tap is detected.

Any ideas about what might be happening, would be greatly appreciated.


#2

I’m having this issue with the ion-list itself! I’m using leaflet, and I’m wondering if that may be interfering.


#3

Same / similar issue here. Works fine during development with ionic serve but the “unrecognised tap” is observed on emulator and ios device.

After returning (back) from a detail screen the first tap on is not recognised. The second one works perfectly.

Observed with ionic2 beta 10 and beta 11


#4

Hi,

I have the same issue with<ion-menu>. But only when it is open with the <ion-navbar> burger-menu-icon. When it is opened with a slide from the left the next click works fine.

I also noticed, that it is not the number of taps but the the time you wait before the next tap. When I open the menu and wait for 2 seconds it will recognize the first tap. If do not wait, it will only recognize the subsequent tap.

Has any one created an issue on github for this?

Thanks,
Benjamin


#5

Also have this issue.


#6

Same here, mostly noticed on the ion-menu.


#7

Are you guys still having this issue or did you find a resolution?

It’s happening to me with buttons inside modals.


#8

Not sure if its of help to you, but I had the issue with Ion-items in list…I realised that ion-item tag with button attribute required two taps for detection, but button tag with ion-item attribute worked on first tap :grin:


#9

I need help: InAppBrowser Insert CSS by File not Working