Ok, this is crazy, but I can not figure out how to upgrade Ionic/CLI to version 7.2.0

Ok, I don’t know what I’m doing wrong… Ionic v 7.2.0 was released today and I want to upgrade to it…

In a terminal window, ionic --version returned 7.1.1 which is what I expected, since I’ve been using that version for a month or so now…

So, to upgrade, I ran the following commands:
sudo npm install -g @ionic/cli@latest
sudo npm install -g @ionic/core@latest
sudo npm install -g @ionic/angular@latest

All of them appeared to complete with no errors, yet ionic --version still returns 7.1.1

Figuring maybe there was something wrong with my npm cache, I ran npm cache clean --force and then re-ran all those sudo npm install commands above…

Same thing: ionic --version still returns 7.1.1

So after all that, I uninstalled ionic completely using the same npm commands above, just with uninstall instead of install. Then I reinstalled using the same npm install commands as before. and the version number is still 7.1.1!!!

W?! T?! ACTUAL?! F?!

What am I doing wrong? Why can I not get version 7.2.0 installed?!!

System Info:
M2 Pro MacBook Pro 16" running MacOS 13.4.1 (c)
NodeJS v 18.17.0
NPM v 9.8.1

Any help would be appreciated

maybe do not available for download. At the npm site the version 7.2.0 not visible.
The lastet is version 7.1.1

If you go here: [Release Notes | Ionic Documentation]
it says the most recent version is 7.2.0. Released today, July 19th.

Maybe it’s npm that’s the problem? It hasn’t gotten the news that 7.2.0 is released?

Ionic CLI and Ionic Framework are different things, the 7.2.0 that was released is Ionic Framework, latest Ionic CLI is 7.1.1.

If you create a new app with Ionic CLI, it will use latest Ionic Framework.

Ohhhhh… Well don’t I feel stupid… I just assumed everything had been upgraded to 7.2.0… Sorry…

No problem, there has always been a big confusion between Ionic CLI and Ionic Framework versions, specially when the CLI version was ahead of the Framework version.