Ionic 2 Beta ionic serve command not launching the app in browser

ionic serve command is not working- check logs-

I already tried reinstalling ioinic@beta and cordova. But when i say ionic serve it exit without starting local server.

Do you have a gulpfile.js in the root directory of the project? Please compare it against the starter app base:

I’m having an issue alike, probably non related, i use serve from Ubuntu, i work in Mac but had to change to Ubuntu, then it stop working, i used the next command to update ionic and then i did ionic serve but the error shows there and the browser didn’t open the app:

npm uninstall -g ionic && npm uninstall -g cordova && npm cache clear && npm cache clean && npm i -g cordova ionic@beta && npm i && ionic serve -s -c

Here’s the output of the serve command:

Can you create an issue for that?

Hi, Thanks for reply,
I have gulpfile.js in root directory of the project. Check root directory-

I have compared all the structure with starter app base everything is same, but still not working… :frowning:

The gulpfile doesn’t have a default gulp task, ionic serve should call the watch task for sass files, i don’t see why are you calling gulp alone in the terminal or cmd.

Done, as soon i get my Mac fixed again i will see if the issue is just with Ubuntu, btw i tried this with a new ‘buildTest2’ project and same result.

If you run gulp sass what is the output?

@brandyshea Here it is-image
Further more ionic serve is working fine on ionic and ionic@alpha projects.

So it is fixed now? if not try this, off course some are Linux commands only, you need to change rm -rf for your OS equivalent, this will clean your pc of ionic, clean npm’s cache and reinstall:

npm uninstall -g ionic && npm uninstall -g cordova && rm -rf node_modules && npm cache clear && npm cache clean && npm i -g cordova ionic@beta && npm i && ionic serve -s -c

I was reading your original image wrong, I didn’t notice you ran gulp by itself after ionic serve. So when you run ionic serve it just stops after

Starting 'watch'...

Can you try running gulp watch and show me what the output is?

Oops! it stucked at after starting watch…
I have also created new template --v2 but no luck…

Off course, it is ‘watching’, try changing a sass file and saving it, it should show 1 more ‘start sass’ and ‘finished sass’ for each time you saved the file.

Hi @brandyshea, Have you got any solution??

Hmm, it’s something we need to research if you get this on a new project as well. Can you create an issue for it and we will look into it:


yup sure, Im getting this problem on every project, i tried npm clear and npm clean and reinstall the ionic@beta and cordova but no luck :pensive:, By the way thanks for your time. Good Luck for --v2 Team Ionic.

1 Like