NEED HELP: `libsass` bindings not found. Try reinstalling `node-sass`?

Hi everyone,

I tried to update my node version and things goes wrong. Now I’ve got this error message :
'libsass' bindings not found. Try reinstalling 'node-sass'?

Anyone has an idea on how to solve it ?

For info, i had node 0.10.26 (if I remember well) and I updated to 0.12.0.
node-sass is installed with version 2.0.1 and I’m using ubuntu 14.04.

1 Like

For info, I tried to downgrade my node version and it worked for node 0.10.36 (sudo n 0.10.36) !
All versions 0.11 and the first 0.12 didn’t worked… :frowning:

So, I go back to work but if someone has an explanation it would be appreciated !

1 Like

same problem over here.

I don’t know if it was because i updated nodejs or ionic framework, but definitively one of those screw up my installation.
My environment
OS: Mac OS X Yosemite
Node Version: v0.12.0
Cordova CLI: 4.3.0
Ionic CLI Version: 1.3.13
Xcode version: Xcode 6.1.1 Build version 6A2008a
ios-sim version: 3.1.1

Hi, try to downgrade node to 0.10.x version : sudo n 0.10.36

2 Likes

downgrading seems to be the only solution for now

2 Likes

You can delete the node_modules/ folder and then run npm install. This solved the issue for me.

5 Likes

it worked for me. thanks

hi you just run

npm install node-sass-middleware

this reason https://github.com/sass/node-sass-middleware

it worked for me. thanks

thanks…its quick fix…I just deleted folder and installed sass again using $ionic setup sass

Had to downgrade node.js as well.
From 0.12 to 0.10.36 (sudo n 0.10.36).

Thanks a lot it worked for me as well

Try following. It worked for me.
npm rebuild node-sass

1 Like

Hi everyone!

I’ve just fixed problems with libsass or node-sass with this command:

$ sudo rm -rf node_modules/ && cat package.json | sed -i.bak 's/"gulp-sass": "^X.X.X"/"gulp-sass": "^2.0.4"/g' package.json && npm install && ionic lib update

Where X is the version of gulp-sass in your package.json

Explanation:

Remove the old files in node_modules. I’m not sure is necessary to use ‘sudo’ (in my case, yes).

$ sudo rm -rf node_modules/

Search and replace inside package.json updating gulp-sass version to ^2.0.4. It also creates a backup (package.json.bak),

$ cat package.json | sed -i.bak 's/"gulp-sass": "^X.X.X"/"gulp-sass": "^2.0.4"/g' package.json

Reinstall dependencies

$ npm install

Update the ionic lib in the project

ionic lib update

If you have any further problems be sure I try can help you…

Bye

3 Likes

Hey

I just tried that to solve my install issue but I get the following on $ionic lib update:

Arthur:ionFullApp_1.3.0 arnaud$ ionic lib update --allow-root

/usr/local/lib/node_modules/bower/node_modules/configstore/index.js:56
throw err;
^

Error: EACCES: permission denied, open '/Users/arnaud/.config/configstore/bower-github.yml’
You don’t have access to this file.

at Error (native)
at Object.fs.openSync (evalmachine.<anonymous>:549:18)
at Object.fs.readFileSync (evalmachine.<anonymous>:397:15)
at Object.create.all.get (/usr/local/lib/node_modules/bower/node_modules/configstore/index.js:34:29)
at Object.Configstore (/usr/local/lib/node_modules/bower/node_modules/configstore/index.js:27:44)
at readCachedConfig (/usr/local/lib/node_modules/bower/lib/config.js:19:23)
at defaultConfig (/usr/local/lib/node_modules/bower/lib/config.js:11:12)
at Object.<anonymous> (/usr/local/lib/node_modules/bower/lib/index.js:40:32)
at Module._compile (module.js:435:26)
at Object.Module._extensions..js (module.js:442:10)`

I went to the mentioned directory and I could not find the file 'bower-github.yml’
Therefore I cannot install sass. :frowning:

Any help is appreciated.

Are you executing this command in the root folder in your project?

Hey

I just saw your answer. Yes I am.
Since then the file has appeared (I do not know how though) and I have been able to compile everything :).

Thanks Gabriele

1 Like

Worked for me.
Thanks a lot.

Downgrading to version 0.10.36 worked for me. Later installed

npm install node-sass

and

npm install gulp-sass

Thanks a lot @lolcknuchel.

1 Like

Thanks! It works for me.

Thanks, gabfiocchi, your solution works.

For those who might struggle to run the entire command, try the following:

  1. Delete the files in your project’s ‘node_modules’ folder.

  2. Change the gulp-sass value in the package.json file to “^2.0.4”.

  3. run ‘npm install’.

These steps worked for me.

5 Likes