Missing binding E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass\vendor\win32-x64-48\binding.node

#1

PATH=E:\Dream Project\PocketBusiness\PocketBusiness.\node_modules.bin;C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\Web Tools\External;%PATH%;C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\Web Tools\External\git
"C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\Web

npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue

npm WARN deprecated graceful-fs@1.2.3: graceful-fs v3.0.0 and before will fail on node releases >= v7.0. Please update to graceful-fs@^4.0.0 as soon as possible. Use ‘npm ls graceful-fs’ to find it in the tree.

System.AggregateException: One or more errors occurred. —> Microsoft.NodejsTools.Npm.PackageJsonException: Error reading package.json at ‘E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp\node_modules\vinyl-fs\node_modules\glob-stream\node_modules\minimatch\node_modules\brace-expansion\node_modules\balanced-match\package.json’: Unable to read package.json. Please ensure the file is valid JSON.

Reading failed because the following error occurred:

Unexpected end when deserializing object. Path ‘keywords[0]’, line 22, position 3. —> Microsoft.NodejsTools.Npm.PackageJsonException: Unable to read package.json. Please ensure the file is valid JSON.

Reading failed because the following error occurred:

Unexpected end when deserializing object. Path ‘keywords[0]’, line 22, position 3. —> Newtonsoft.Json.JsonSerializationException: Unexpected end when deserializing object. Path ‘keywords[0]’, line 22, position 3.
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateJObject(JsonReader reader)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateObject(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, JsonContainerContract containerContract, JsonProperty containerMember, Object existingValue)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateValueInternal(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, JsonContainerContract containerContract, JsonProperty containerMember, Object existingValue)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.Deserialize(JsonReader reader, Type objectType, Boolean checkAdditionalContent)
at Newtonsoft.Json.JsonSerializer.DeserializeInternal(JsonReader reader, Type objectType)
at Newtonsoft.Json.JsonConvert.DeserializeObject(String value, Type type, JsonSerializerSettings settings)
at Microsoft.NodejsTools.Npm.ReaderPackageJsonSource…ctor(TextReader reader)
— End of inner exception stack trace —
at Microsoft.NodejsTools.Npm.ReaderPackageJsonSource.WrapExceptionAndRethrow(Exception ex)
at Microsoft.NodejsTools.Npm.ReaderPackageJsonSource…ctor(TextReader reader)
at Microsoft.NodejsTools.Npm.FilePackageJsonSource…ctor(String fullPathToFile)
— End of inner exception stack trace —
at Microsoft.NodejsTools.Npm.FilePackageJsonSource.WrapExceptionAndRethrow(String fullPathToFile, Exception ex)
at Microsoft.NodejsTools.Npm.FilePackageJsonSource…ctor(String fullPathToFile)
at Microsoft.NodejsTools.Npm.DirectoryPackageJsonSource…ctor(String fullDirectoryPath)
at Microsoft.NodejsTools.Npm.SPI.RootPackage…ctor(String fullPathToRootDirectory, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.NodeModules…ctor(IRootPackage parent, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.RootPackage…ctor(String fullPathToRootDirectory, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.NodeModules…ctor(IRootPackage parent, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.RootPackage…ctor(String fullPathToRootDirectory, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.NodeModules…ctor(IRootPackage parent, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.RootPackage…ctor(String fullPathToRootDirectory, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.NodeModules…ctor(IRootPackage parent, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.RootPackage…ctor(String fullPathToRootDirectory, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.NodeModules…ctor(IRootPackage parent, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.RootPackage…ctor(String fullPathToRootDirectory, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.NodeModules…ctor(IRootPackage parent, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.RootPackage…ctor(String fullPathToRootDirectory, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.NpmController.d__1.MoveNext()
— End of inner exception stack trace —
—> (Inner Exception #0) Microsoft.NodejsTools.Npm.PackageJsonException: Error reading package.json at ‘E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp\node_modules\vinyl-fs\node_modules\glob-stream\node_modules\minimatch\node_modules\brace-expansion\node_modules\balanced-match\package.json’: Unable to read package.json. Please ensure the file is valid JSON.

Reading failed because the following error occurred:

Unexpected end when deserializing object. Path ‘keywords[0]’, line 22, position 3. —> Microsoft.NodejsTools.Npm.PackageJsonException: Unable to read package.json. Please ensure the file is valid JSON.

Reading failed because the following error occurred:

Unexpected end when deserializing object. Path ‘keywords[0]’, line 22, position 3. —> Newtonsoft.Json.JsonSerializationException: Unexpected end when deserializing object. Path ‘keywords[0]’, line 22, position 3.
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateJObject(JsonReader reader)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateObject(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, JsonContainerContract containerContract, JsonProperty containerMember, Object existingValue)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.CreateValueInternal(JsonReader reader, Type objectType, JsonContract contract, JsonProperty member, JsonContainerContract containerContract, JsonProperty containerMember, Object existingValue)
at Newtonsoft.Json.Serialization.JsonSerializerInternalReader.Deserialize(JsonReader reader, Type objectType, Boolean checkAdditionalContent)
at Newtonsoft.Json.JsonSerializer.DeserializeInternal(JsonReader reader, Type objectType)
at Newtonsoft.Json.JsonConvert.DeserializeObject(String value, Type type, JsonSerializerSettings settings)
at Microsoft.NodejsTools.Npm.ReaderPackageJsonSource…ctor(TextReader reader)
— End of inner exception stack trace —
at Microsoft.NodejsTools.Npm.ReaderPackageJsonSource.WrapExceptionAndRethrow(Exception ex)
at Microsoft.NodejsTools.Npm.ReaderPackageJsonSource…ctor(TextReader reader)
at Microsoft.NodejsTools.Npm.FilePackageJsonSource…ctor(String fullPathToFile)
— End of inner exception stack trace —
at Microsoft.NodejsTools.Npm.FilePackageJsonSource.WrapExceptionAndRethrow(String fullPathToFile, Exception ex)
at Microsoft.NodejsTools.Npm.FilePackageJsonSource…ctor(String fullPathToFile)
at Microsoft.NodejsTools.Npm.DirectoryPackageJsonSource…ctor(String fullDirectoryPath)
at Microsoft.NodejsTools.Npm.SPI.RootPackage…ctor(String fullPathToRootDirectory, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.NodeModules…ctor(IRootPackage parent, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.RootPackage…ctor(String fullPathToRootDirectory, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.NodeModules…ctor(IRootPackage parent, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.RootPackage…ctor(String fullPathToRootDirectory, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.NodeModules…ctor(IRootPackage parent, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.RootPackage…ctor(String fullPathToRootDirectory, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.NodeModules…ctor(IRootPackage parent, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.RootPackage…ctor(String fullPathToRootDirectory, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.NodeModules…ctor(IRootPackage parent, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.RootPackage…ctor(String fullPathToRootDirectory, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.NodeModules…ctor(IRootPackage parent, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.RootPackage…ctor(String fullPathToRootDirectory, Boolean showMissingDevOptionalSubPackages)
at Microsoft.NodejsTools.Npm.SPI.NpmController.d__1.MoveNext()<—

npm http GET https://registry.npmjs.org/graceful-fs
npm http GET https://registry.npmjs.org/strip-bom
npm http GET https://registry.npmjs.org/ini
npm http GET https://registry.npmjs.org/parse-json
npm http GET https://registry.npmjs.org/fill-range
npm http GET https://registry.npmjs.org/lcid
npm http GET https://registry.npmjs.org/pify
npm http GET https://registry.npmjs.org/code-point-at
npm http GET https://registry.npmjs.org/is-unc-path
npm http GET https://registry.npmjs.org/pinkie
npm http GET https://registry.npmjs.org/strip-ansi
npm http GET https://registry.npmjs.org/is-finite
npm http GET https://registry.npmjs.org/is-fullwidth-code-point
npm http GET https://registry.npmjs.org/strip-ansi
npm http GET https://registry.npmjs.org/extsprintf
npm http GET https://registry.npmjs.org/spdx-license-ids
npm http GET https://registry.npmjs.org/wrap-ansi
npm http GET https://registry.npmjs.org/json-schema
npm http GET https://registry.npmjs.org/verror
npm http GET https://registry.npmjs.org/glob-parent
npm http GET https://registry.npmjs.org/dashdash
npm http GET https://registry.npmjs.org/getpass
npm http GET https://registry.npmjs.org/jsbn
npm http GET https://registry.npmjs.org/tweetnacl
npm http GET https://registry.npmjs.org/ecc-jsbn
npm http GET https://registry.npmjs.org/bcrypt-pbkdf
npm http GET https://registry.npmjs.org/asn1
npm http 304 https://registry.npmjs.org/graceful-fs
npm http 304 https://registry.npmjs.org/strip-bom
npm http 304 https://registry.npmjs.org/ini
npm http 304 https://registry.npmjs.org/parse-json
npm http GET https://registry.npmjs.org/co
npm http GET https://registry.npmjs.org/json-stable-stringify
npm http 304 https://registry.npmjs.org/fill-range
npm http 304 https://registry.npmjs.org/lcid
npm http 304 https://registry.npmjs.org/pify
npm http 304 https://registry.npmjs.org/code-point-at
npm http 304 https://registry.npmjs.org/is-unc-path
npm http 304 https://registry.npmjs.org/pinkie
npm http GET https://registry.npmjs.org/is-utf8
npm http GET https://registry.npmjs.org/invert-kv
npm http GET https://registry.npmjs.org/error-ex
npm http 304 https://registry.npmjs.org/is-finite
npm http 304 https://registry.npmjs.org/is-fullwidth-code-point
npm http 304 https://registry.npmjs.org/extsprintf
npm http GET https://registry.npmjs.org/is-number
npm http GET https://registry.npmjs.org/unc-path-regex
npm http GET https://registry.npmjs.org/repeat-string
npm http GET https://registry.npmjs.org/randomatic
npm http 304 https://registry.npmjs.org/strip-ansi
npm http 304 https://registry.npmjs.org/strip-ansi
npm http 304 https://registry.npmjs.org/spdx-license-ids
npm http 304 https://registry.npmjs.org/wrap-ansi
npm http GET https://registry.npmjs.org/number-is-nan
npm http 304 https://registry.npmjs.org/json-schema
npm http 304 https://registry.npmjs.org/verror
npm http 304 https://registry.npmjs.org/glob-parent
npm http GET https://registry.npmjs.org/ansi-regex
npm http 304 https://registry.npmjs.org/dashdash
npm http 304 https://registry.npmjs.org/getpass
npm http 304 https://registry.npmjs.org/jsbn
npm http 304 https://registry.npmjs.org/tweetnacl
npm http 304 https://registry.npmjs.org/ecc-jsbn
npm http 304 https://registry.npmjs.org/bcrypt-pbkdf
npm http 304 https://registry.npmjs.org/asn1
npm http 304 https://registry.npmjs.org/co
npm http 304 https://registry.npmjs.org/json-stable-stringify
npm http 304 https://registry.npmjs.org/is-utf8
npm WARN engine co@4.6.0: wanted: {“iojs”:">= 1.0.0",“node”:">= 0.12.0"} (current: {“node”:“v0.10.31”,“npm”:“1.4.9”})
npm http 304 https://registry.npmjs.org/invert-kv
npm http 304 https://registry.npmjs.org/error-ex
npm http 304 https://registry.npmjs.org/is-number
npm http 304 https://registry.npmjs.org/unc-path-regex
npm http 304 https://registry.npmjs.org/repeat-string
npm http GET https://registry.npmjs.org/jsonify
npm http GET https://registry.npmjs.org/is-arrayish
npm http 304 https://registry.npmjs.org/randomatic
npm http 304 https://registry.npmjs.org/number-is-nan
npm http 304 https://registry.npmjs.org/ansi-regex
npm http GET https://registry.npmjs.org/isarray
npm http 304 https://registry.npmjs.org/jsonify
npm http 304 https://registry.npmjs.org/is-arrayish
npm http 304 https://registry.npmjs.org/isarray

node-sass@3.14.0-0 install E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass
node scripts/install.js
Cached binary found at C:\Users\Lunar Satellite\AppData\Roaming\npm-cache\node-sass\3.14.0-0\win32-ia32-11_binding.node
node-sass@3.14.0-0 postinstall E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass
node scripts/build.js
Binary found at E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass\vendor\win32-ia32-11\binding.node
Testing binary
Binary is fine
io.cordova.myappe0e48e@1.1.1 postinstall E:\Dream Project\PocketBusiness\PocketBusiness
npm run bower && npm run build
io.cordova.myappe0e48e@1.1.1 bower E:\Dream Project\PocketBusiness\PocketBusiness
bower install
bower invalid-meta for:E:\Dream Project\PocketBusiness\PocketBusiness\bower.json
bower invalid-meta The “name” is recommended to be lowercase, can contain digits, dots, dashes
io.cordova.myappe0e48e@1.1.1 build E:\Dream Project\PocketBusiness\PocketBusiness
gulp
E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass\lib\binding.js:15
throw new Error(errors.missingBinary());
^
Error: Missing binding E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass\vendor\win32-x64-48\binding.node
Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 6.x
Found bindings for the following environments:

  • Windows 32-bit with Node 0.10.x
    This usually happens because your environment has changed since running npm install.
    Run npm rebuild node-sass to build the binding for your current environment.
    at module.exports (E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass\lib\binding.js:15:13)
    at Object. (E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass\lib\index.js:14:35)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions…js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object. (E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\index.js:187:21)
    npm ERR! Windows_NT 10.0.10240
    npm ERR! argv “C:\Program Files (x86)\nodejs\node.exe” “C:\Program Files (x86)\nodejs\node_modules\npm\bin\npm-cli.js” “run” "build"
    npm ERR! node v6.11.1
    npm ERR! npm v3.10.10
    npm ERR! code ELIFECYCLE
    npm ERR! io.cordova.myappe0e48e@1.1.1 build: gulp
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the io.cordova.myappe0e48e@1.1.1 build script ‘gulp’.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the io.cordova.myappe0e48e package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR! gulp
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR! npm bugs io.cordova.myappe0e48e
    npm ERR! Or if that isn’t available, you can get their info via:
    npm ERR! npm owner ls io.cordova.myappe0e48e
    npm ERR! There is likely additional logging output above.
    npm ERR! Please include the following file with any support request:
    npm ERR! E:\Dream Project\PocketBusiness\PocketBusiness\npm-debug.log
    npm ERR! io.cordova.myappe0e48e@1.1.1 postinstall: npm run bower && npm run build
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the io.cordova.myappe0e48e@1.1.1 postinstall script.
    npm ERR! This is most likely a problem with the io.cordova.myappe0e48e package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR! npm run bower && npm run build
    npm ERR! You can get their info via:
    npm ERR! npm owner ls io.cordova.myappe0e48e
    npm ERR! There is likely additional logging output above.
    npm ERR! System Windows_NT 6.2.9200
    npm ERR! command “C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\Web Tools\External\\node\node” “C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\Web Tools\External\npm\node_modules\npm\bin\npm-cli.js” "install"
    npm ERR! cwd E:\Dream Project\PocketBusiness\PocketBusiness
    npm ERR! node -v v0.10.31
    npm ERR! npm -v 1.4.9
    npm ERR! code ELIFECYCLE
    npm

====npm command completed with exit code 1====

PATH=E:\Dream Project\PocketBusiness\PocketBusiness.\node_modules.bin;C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\Web Tools\External;%PATH%;C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\Web Tools\External\git
"E:\Dream Project\PocketBusiness\PocketBusiness.\node_modules.bin\Bower.cmd" install --force-latest
bower invalid-meta for:E:\Dream Project\PocketBusiness\PocketBusiness\bower.json
bower invalid-meta The “name” is recommended to be lowercase, can contain digits, dots, dashes
====Executing command ‘npm install’====

npm WARN package.json io.cordova.myappe0e48e@1.1.1 No repository field.

io.cordova.myappe0e48e@1.1.1 postinstall E:\Dream Project\PocketBusiness\PocketBusiness
npm run bower && npm run build
io.cordova.myappe0e48e@1.1.1 bower E:\Dream Project\PocketBusiness\PocketBusiness
bower install
bower invalid-meta for:E:\Dream Project\PocketBusiness\PocketBusiness\bower.json
bower invalid-meta The “name” is recommended to be lowercase, can contain digits, dots, dashes
io.cordova.myappe0e48e@1.1.1 build E:\Dream Project\PocketBusiness\PocketBusiness
gulp
E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass\lib\binding.js:15
throw new Error(errors.missingBinary());
^
Error: Missing binding E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass\vendor\win32-x64-48\binding.node
Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 6.x
Found bindings for the following environments:

  • Windows 32-bit with Node 0.10.x
    This usually happens because your environment has changed since running npm install.
    Run npm rebuild node-sass to build the binding for your current environment.
    at module.exports (E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass\lib\binding.js:15:13)
    at Object. (E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass\lib\index.js:14:35)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions…js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object. (E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\index.js:187:21)
    npm ERR! Windows_NT 10.0.10240
    npm ERR! argv “C:\Program Files (x86)\nodejs\node.exe” “C:\Program Files (x86)\nodejs\node_modules\npm\bin\npm-cli.js” “run” "build"
    npm ERR! node v6.11.1
    npm ERR! npm v3.10.10
    npm ERR! code ELIFECYCLE
    npm ERR! io.cordova.myappe0e48e@1.1.1 build: gulp
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the io.cordova.myappe0e48e@1.1.1 build script ‘gulp’.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the io.cordova.myappe0e48e package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR! gulp
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR! npm bugs io.cordova.myappe0e48e
    npm ERR! Or if that isn’t available, you can get their info via:
    npm ERR! npm owner ls io.cordova.myappe0e48e
    npm ERR! There is likely additional logging output above.
    npm ERR! Please include the following file with any support request:
    npm ERR! E:\Dream Project\PocketBusiness\PocketBusiness\npm-debug.log
    npm ERR! io.cordova.myappe0e48e@1.1.1 postinstall: npm run bower && npm run build
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the io.cordova.myappe0e48e@1.1.1 postinstall script.
    npm ERR! This is most likely a problem with the io.cordova.myappe0e48e package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR! npm run bower && npm run build
    npm ERR! You can get their info via:
    npm ERR! npm owner ls io.cordova.myappe0e48e
    npm ERR! There is likely additional logging output above.
    npm ERR! System Windows_NT 6.2.9200
    npm ERR! command “C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\Web Tools\External\\node\node” “C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\Web Tools\External\npm\node_modules\npm\bin\npm-cli.js” "install"
    npm ERR! cwd E:\Dream Project\PocketBusiness\PocketBusiness
    npm ERR! node -v v0.10.31
    npm ERR! npm -v 1.4.9
    npm ERR! code ELIFECYCLE
    npm

====npm command completed with exit code 1====

PATH=E:\Dream Project\PocketBusiness\PocketBusiness.\node_modules.bin;C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\Web Tools\External;%PATH%;C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\Web Tools\External\git
"E:\Dream Project\PocketBusiness\PocketBusiness.\node_modules.bin\Bower.cmd" install --force-latest
bower invalid-meta for:E:\Dream Project\PocketBusiness\PocketBusiness\bower.json
bower invalid-meta The “name” is recommended to be lowercase, can contain digits, dots, dashes
====Executing command ‘npm install’====

npm WARN package.json io.cordova.myappe0e48e@1.1.1 No repository field.

io.cordova.myappe0e48e@1.1.1 postinstall E:\Dream Project\PocketBusiness\PocketBusiness
npm run bower && npm run build
io.cordova.myappe0e48e@1.1.1 bower E:\Dream Project\PocketBusiness\PocketBusiness
bower install
bower invalid-meta for:E:\Dream Project\PocketBusiness\PocketBusiness\bower.json
bower invalid-meta The “name” is recommended to be lowercase, can contain digits, dots, dashes
io.cordova.myappe0e48e@1.1.1 build E:\Dream Project\PocketBusiness\PocketBusiness
gulp
E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass\lib\binding.js:15
throw new Error(errors.missingBinary());
^
Error: Missing binding E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass\vendor\win32-x64-48\binding.node
Node Sass could not find a binding for your current environment: Windows 64-bit with Node.js 6.x
Found bindings for the following environments:

  • Windows 32-bit with Node 0.10.x
    This usually happens because your environment has changed since running npm install.
    Run npm rebuild node-sass to build the binding for your current environment.
    at module.exports (E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass\lib\binding.js:15:13)
    at Object. (E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\node_modules\node-sass\lib\index.js:14:35)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions…js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object. (E:\Dream Project\PocketBusiness\PocketBusiness\node_modules\gulp-sass\index.js:187:21)
    npm ERR! Windows_NT 10.0.10240
    npm ERR! argv “C:\Program Files (x86)\nodejs\node.exe” “C:\Program Files (x86)\nodejs\node_modules\npm\bin\npm-cli.js” “run” "build"
    npm ERR! node v6.11.1
    npm ERR! npm v3.10.10
    npm ERR! code ELIFECYCLE
    npm ERR! io.cordova.myappe0e48e@1.1.1 build: gulp
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the io.cordova.myappe0e48e@1.1.1 build script ‘gulp’.
    npm ERR! Make sure you have the latest version of node.js and npm installed.
    npm ERR! If you do, this is most likely a problem with the io.cordova.myappe0e48e package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR! gulp
    npm ERR! You can get information on how to open an issue for this project with:
    npm ERR! npm bugs io.cordova.myappe0e48e
    npm ERR! Or if that isn’t available, you can get their info via:
    npm ERR! npm owner ls io.cordova.myappe0e48e
    npm ERR! There is likely additional logging output above.
    npm ERR! Please include the following file with any support request:
    npm ERR! E:\Dream Project\PocketBusiness\PocketBusiness\npm-debug.log
    npm ERR! io.cordova.myappe0e48e@1.1.1 postinstall: npm run bower && npm run build
    npm ERR! Exit status 1
    npm ERR!
    npm ERR! Failed at the io.cordova.myappe0e48e@1.1.1 postinstall script.
    npm ERR! This is most likely a problem with the io.cordova.myappe0e48e package,
    npm ERR! not with npm itself.
    npm ERR! Tell the author that this fails on your system:
    npm ERR! npm run bower && npm run build
    npm ERR! You can get their info via:
    npm ERR! npm owner ls io.cordova.myappe0e48e
    npm ERR! There is likely additional logging output above.
    npm ERR! System Windows_NT 6.2.9200
    npm ERR! command “C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\Web Tools\External\\node\node” “C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE\Extensions\Microsoft\Web Tools\External\npm\node_modules\npm\bin\npm-cli.js” "install"
    npm ERR! cwd E:\Dream Project\PocketBusiness\PocketBusiness
    npm ERR! node -v v0.10.31
    npm ERR! npm -v 1.4.9
    npm ERR! code ELIFECYCLE
    npm

====npm command completed with exit code 1====