Error: Missing binding /usr/src/app/node_modules/node-sass/vendor/linux-x64-57


#1

Hi, I have a big trouble with this.
I have been reading a lot of this issue, but I didn’t get the solution.

Can someone help me, please?

Error: Missing binding /usr/src/app/node_modules/node-sass/vendor/linux-x64-57     
/binding.node Node Sass could not find a binding for your current environment: Linux 64-bit 
with Node.js 8.x Found bindings for the following environments: - OS X 64-bit with Node.js 
8.x This usually happens because your environment has changed since running `npm install`. 
Run **npm rebuild node-sass --force** to build the binding for your current environment. at 
module.exports (/usr/src/app/node_modules/node-sass/lib/binding.js:15:13) at Object. 
(/usr/src/app/node_modules/node-sass/lib/index.js:14:35)
at Module._compile (module.js:569:30)
at Object.Module._extensions..js (module.js:580:10)
at Module.load (module.js:503:32)
at tryModuleLoad (module.js:466:12)
at Function.Module._load (module.js:458:3)
at Module.require (module.js:513:17)
at require (internal/module.js:11:18)
at Object. (/usr/src/app/node_modules/@ionic/app-scripts/dist/core/bundle-components.js:6:16)
npm info lifecycle PaymentReceiver@0.0.1~build: Failed to exec build script
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! PaymentReceiver@0.0.1 build: `ionic-app-scripts build` 
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the PaymentReceiver@0.0.1 build script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output      
above.

I executed “npm rebuild node-sass --force” and in the beginning threw me an issue with the version of Python “my version was python3.6” I read about node-gyp not support that version of Python and recommend this one 2.7, because of that I executed

npm config set python /usr/bin/python2.7

delete all node-modules

npm install

and the command “npm rebuild node-sass --force” works ok!
but I get the same error :frowning:
If someone can explain to me what is my problem, I really really Appreciate!!

My ionic info is:

cli packages: (/usr/local/lib/node_modules)
@ionic/cli-utils  : 1.19.2    ionic (Ionic CLI) : 3.20.0
global packages:    cordova (Cordova CLI) : 6.5.0
local packages:    @ionic/app-scripts : 3.1.8    Cordova Platforms  : android 6.1.2 browser   4.1.0 ios 4.4.0
Ionic Framework    : ionic-angular 3.9.2System:
ios-deploy : 1.9.2
Node       : v8.11.1
npm        : 5.6.0
OS         : macOS High Sierra

Environment Variables:

ANDROID_HOME : /Users/raulsagastume/Users/raulsagastume/Library/Android/sdk/

Misc:

backend : pro

I tried with differents versions of node and npm but nothing happened.