Magical border showing up

Hey there, I’m trying to get rid of the bottom border on all my navbars

I have this CSS

.bar {
    border: none !important;
    border-bottom: none !important;
    border-color: transparent !important;

It works great in browser

But on my iPhone simulator there is a dark border there, LOOK CLOSELY :smile:

Any reason why this would be there?

i also have this problem but when i start to use crosswalk its become ok and the line is gone

Hmm, if its an iOS device, could you remote inspect with iOS and see if any css is being applied?
Haven’t seen this before some I’m a bit unfamiliar with the issue.

@mhartington I’ve tried debugging it with Safari, but the only HTML I get is my index.html, nothing inside of my <ion-nav-view>, is there a way to do that? Thanks.

Hmm, should be able to…

I got your email, any way you could shoot me a copy of the project?



That’s all I get.

I followed this tutorial.

My project is huge, I could send you the www folder if you’d like, but it’d be pain for you to get it running on an emulator.

Yeah if you want to zip that up I can throw that into a new project and see whats up.

Oh it looks like I’m only viewing the index.html file, I’m not exactly sure where to Inspect Element with Safari like you do with Chrome.

ahh alright, you should see a setting up to select source code or dom tree…


Select DOM tree

Just figured that out :slight_smile:

Okay, I found the border.

background-image: linear-gradient(0deg, #111, #111 50%, transparent 50%);

If I uncheck that, it makes that dark border white instead. Setting background-image: none seems to have worked!


Glad to hear.