Lesson learned about minSDKversion for android

I upgraded my app from ionic 3 to ionic 5 and without changing the default sdk level( minSDKversion 21). And I didn’t tested the app on the minSDKVersion 21(Android 5) either which was stupid. Some of my customers upgraded their app and the app crashed on their tablets because they got very old tablet with android version 5.0. After some incidents reports came in, I tested what the minSDKVersion is supported and it was 25 which was android version 7. So I made the decision of dropping support for any devices older than android version 7.1 and pushed an update to the Google Play Console. Sharing this lesson learned with the others and I hope you can learn from it.