Latest official version of Angular that latest Ionic 3 supports


#1

Since Ionic 3 relies on Angular I wonder if there is official “list” of Angular dependencies that Ionic 3.9.2 supports.
For now I just assume whatever is installed with Ionic is that “official” proposed one.


#2

@morphist Ionic 3.9.0 till 3.9.2 supports the following dependencies:

"dependencies" : {
  ...
  "@angular/common": "5.0.0",
  "@angular/compiler": "5.0.0",
  "@angular/compiler-cli": "5.0.0",
  "@angular/core": "5.0.0",
  "@angular/forms": "5.0.0",
  "@angular/http": "5.0.0",
  "@angular/platform-browser": "5.0.0",
  "@angular/platform-browser-dynamic": "5.0.0",
  "@ionic/storage": "2.1.3",
  "ionic-angular": "3.9.0",
  "rxjs": "5.5.2",
  "zone.js": "0.8.18"
  ...
},
"devDependencies: {
  "@ionic/app-scripts": "3.1.0",
  "typescript" : "2.4.2"
}

Source (their official v3 branch changelog):

Some of those can be changed. I have:

"rxjs": "^6.1.0",
"rxjs-compat": "^6.1.0",

and

"@ionic/app-scripts": "^3.1.7",

They don’t support rxjs6 so I use rxjs-compat to provide backwards compatibility (a pity, because the size of the build is big, but at least I wll have to just remove this package when using in Ionic4).


#3

Thank you. So basically change log can be that source for me then;)


#4

Do you have your latest Ionic V3 Version with the latest framework versions you’ve used on V3? Angular/Rxjs etc.

Thanks!


#5

@tdtechlink I’m using a package.json like the one in my previous post in my v3 app. I saw people using Angular 6 and 7, but be careful that it could cause incompatibility problems (theoretically). I use ionic cli 4.0.5. Is that what you wanted to know?


#6

Thanks @lucasbasquerotto! I really appreciate it. I’m in a dependency nightmare.

So you’re not upgrading to 5.x.y and staying specifically at 5.0.0?

What sort of “problems” would angular 6/7 cause?


#7

@tdtechlink I think it will work fine with 5.x.y because it’s the same major version (theoretically, it should be fine).

The problems may happen when upgrading to Angular6+.

One example is the case I cited above.

Angular6 uses rxjs6 and ionic3 uses rxjs5, and both of them are incompatible.

You can use rxjs-compat to solve this specific case, but it might have other incompatibilities (aside from rxjs).

I don’t know if they would really be incompatible for other features, but for a production app you should pay attention to possible incompatibilities to avoid unexpected errors due to that.

This is a comment from someone from the ionic team about it:

Other posts:

In most cases you see people saying to use Angular5, but in some cases you see people saying that they where able to use Angular6. Just be careful if you use Angular6 with Ionic3 regarding possible incompatibilities.