Keep getting Platform ios is not installed! Would you like to install it?


#1

Every time I run ionic cordova build ios, I keep getting the message:

Platform ios is not installed! Would you like to install it?

even though the platform has already been installed

running node version 8.5, npm 5.3, latest versions of ionic etc.

I ran ionic cordova platform remove ios, and then re-added it, and that’s when this problem began


#2

Same problem here! Did you fix it?


#3

I think it has to do with cordova-ios, make sure its version 4.4 not 4.5


#4

Ok! Thank you!
I removed ios platform, upgrade node and thats working again!


#5

with which version it works?


#6

Hi!
Node v6.9.5. See:

@ionic/cli-utils  : 1.9.2
ionic (Ionic CLI) : 3.9.2

local packages:

@ionic/app-scripts : 0.0.30
Ionic Framework    : ionic-angular 2.3.0

System:

Node : v6.9.5
npm  : 3.10.10
OS   : Windows 7