Ios-sim was not found. Installing it doesn't seem to work

I’m trying to start using ionic but i get this error when i try to emulate:

ios-sim was not found. Please download, build and install version 3.0.0 or greater from into your path. Or 'npm install -g ios-sim' using node.js:
Error: /Applications/MAMP/htdocs/topicChat/platforms/ios/cordova/run: Command failed with exit code 2
    at ChildProcess.whenDone (/usr/local/lib/node_modules/cordova/node_modules/cordova-lib/src/cordova/superspawn.js:131:23)
    at ChildProcess.emit (events.js:110:17)
    at maybeClose (child_process.js:1015:16)
    at Process.ChildProcess._handle.onexit (child_process.js:1087:5)

This is after already installing ios-sim, i once again installed it but i keep getting the same error.
Any thoughts? I’ve read a few posts with similar problems and non of the solutions have worked

Hey @ernerock,

If you open your terminal and type in ios-sim does it respond appropriately? Aka show the options. Also if you want to run ionic build ios and then ionic emulate ios.


if I type ios-sim i get

-bash: ios-sim: command not found

however when i run sudo npm install -g ios-sim it runs without issues and displays ** BUILD SUCCEEDED **

1 Like

Did you ever get it to work?