Ios build sometimes broken


#1

This is my first post so if this is the wrong place for it let me know. We have the following issue with our app. Our ios build (on El Capitan with xcode 7.2.1) works most of the times after you install it.
But for some reason sometimes when I install it on an device, it gets stuck on our login screen (the first view of the app). Clicking on elements in the login form does not work, the keyboard is not appearing and the buttons on the login screen are also not working. Once this happens the app remains broken even if one kills it and restarts it.

Reinstalling the app several times solves the issue (at the moment the installation is done using testflight as we are still testing). Could anybody give me some guidance on how to debug this?

Best Niels


#2

Hi @nveldik

I have the same problem. If you get a soloution I would be interested in it.

Regards,
Daniel


#3

You may have fixed this issue already but I also had something similar to this. I’m not sure what other plugins you may have installed, but I know Cordova for iOS had a bug in 4.0.1 that caused apps to freeze. https://issues.apache.org/jira/browse/CB-10530


#4

I fixed it with the steps described in the following forum post:


#5

Hi everybody,

Thanks for all the feedback! I independently also tried a newer Cordova version (went from 6.0.0 to 6.1.1) which seems to solve the issue.

Still really annoying it would be great to learn how to debug this in the future…

Cheers Niels