iOS build fails after plugin installation


#1

I have issues with my status bar and deinstalled all the pluings as advised here.
Now I successfully reinstalled the cordova device plugin, but when I try to build iOS I receive an error message:

The following build commands failed:

CompileC build/healthcare.build/Debug-iphonesimulator/healthcare.build/Objects-normal/i386/CDVDevice.o healthcare/Plugins/org.apache.cordova.device/CDVDevice.m normal i386 objective-c com.apple.compilers.llvm.clang.1_0.compiler
(1 failure)
Error: /Users/ched/healthcare/platforms/ios/cordova/build: Command failed with exit code 65
 at ChildProcess.whenDone (/usr/local/lib/node_modules/cordova/node_modules/cordova-lib/src/cordova/superspawn.js:135:23)
    at ChildProcess.EventEmitter.emit (events.js:98:17)
    at maybeClose (child_process.js:743:16)

    at Process.ChildProcess._handle.onexit (child_process.js:810:5)

I originally used the demo seed project and never had any other plugins installed. Can someone please tell me why I’m encountering this issue and if it might be related to my other problem?


Navbar under status bar
#2

After adding a new plugin, build or prepare commands does not copy objective c files to project folders.

  • Remove ios platform then add platform again.

    $ cordova platform remove ios
    $ cordova platform add ios

  • Or you can manualy copy objective-c files and resources for the plugin to project folder.


#3

Sorry, I messed up the link AND my notification settings. As pointed out in the other post that’s not the issue, as I removed and re-added the platforms without any success. I really have no clue why this problems appear in a seed-project.


#4

Apparently

$ cordova platform remove ios
$ cordova platform add ios

worked, used “ionic platform remove ios” before, which didn’t work. Still no solution for the other problem though :frowning:.