IOS build failing in IONIC


#1

Hi,

I am getting “Error: doc.find is not a function” error when IONIC is trying to do IOS build.

IONIC is able to build Android successfully. Only issue is with IOS.

Any help is appreciated.


#2

What is your ionic info output?
What command are you executing?
What is its complete output?


#3

Ionic Info Output -
Cordova CLI - 7.0.1
Ionic CLI Version - 2.1.18
ios-deploy version: Not installed
ios-sim version: Not installed
OS: Windows 7
Node Version: v4.4.4
Xcode version: Not installed

Command - ionic package build ios

Complete Output -“Error: doc.find is not a function"

Is this due to ios-deploy version not installed?


#4

That is ancient and not supported any more. You should upgrade: npm i -g ionic


#5

But through the same version my android is building successfully. Is this specific to IOS?


#6

I did not say that it doesn’t work any more. But there are >1 year of bug fixing and changes in all libraries that can cause all kinds of problems.

There is no reason not to update as the CLi is totally disconnected from your application library versions.


#7

Sorry for confusion, I just noticed that CLI version 2.1.18 I am using is wrong, I am not using Ionic 2 but Ionic 1. I am not sure how that version was upgraded. So I installed 1.7 which was my previous version and now my ionic info is

Cordova CLI - 7.0.1
Ionic CLI Version - 1.7.16
Ionic App Lib Version - 0.7.3
Gulp version - CLI version 3.9.1
Gulp local - Local version 3.9.1
OS: Windows 7 SP1
Node Version: v4.4.4

I gulped it again and try to built the IOS build, still it is failing


#8

Ionic CLI is different from Ionic Framework.
You can run the newest version of Ionic CLI with a super old Ionic v1 app.


#9

-> OS: Windows 7

@Sujan12 he’s using Windows so he can’t build for iOS.


#10

I was able to build it till last week.


#11

How do you build and deploy for iOS without XCode?


#12

For packaging app we use ionic, ionic package build ios.

And getting error in IONIC after that.


#13

They can build via Ionic Package (that will be going away soon as Ionic Cloud is being sunset), but without upgrading the CLI there is no way to understand what is going wrong for them.


#14

Hi Sujan/ Robinyo,

Thanks for your replies, I upgraded my CLI version, after upgrading it ask me to upgrade my node version to 8 and when i tried to do it , it is throwing some error. I am investigating on this issue, once I am through it I will try to build it and let you know if it works or any issues


#15

Ok, so I was able to resolve this issue. I created new folder copied my existing source code (excluding node_modules) and installed only specific plugins and it started working :slight_smile:

I think custom-config-plugin which I was trying to use was causing the issue, either it was not properly installed or something cause ios build to fail. Even i tried to remove the plugin and may be some garbage from that plugin was still hiding in some libraries.

But now it is working fine. Appreciate your help!!