IOS BUG - Input search get focused only on second click but keyboard is visible from the first one

Hi !
I have an input type search and when I click it ones the keyboard appears but input doesn’t get focused and keyboard visible class on body not exist.

If I click it again on it everithing’s fine …I get focus on input, the keyboard visible class appears on body and I’m able to write in it

This is only on IOS. It’s weird cause on other input (text, password) it’s working fine …
Can somebody help me to solve this issue ? It’s fustrated to click twice on a input to be able to edit


Hello I have exactly the same issue

Same here. It’s difficult to reproduce as it is not happening every time

I solved that issue. It was something really weird. That problem was caused by some issue in my DB (sqlite). When DB freezed sometimes and just on some inputs I had to double tap to focus.

I just did an upgrate to Apache Cordova iOS 3.8.0 ( and everything is works perfect now.

And …just in the case that your screen is jumping up when you tap in an input you can add this to fix :


Yes same issue with me. I also created a Stackoverflow question.

I have to actually set the focus manually on my textarea in order for ios keyboard to show. Then ios keyboard steals the focus back from textarea, requiring a click in the text area before you can start typing. This is really a mess. I am using the ionic.keyboard plugin.

Has anybody found a solution or workaround to this issue?

Commenting to say we still have the issue too.

This is happening to me on URL input types. It takes two clicks to focus the input.

same here :frowning: any suggestions guys ?

I had a similar issue once. But I am not sure if it is the same issue.
A text input was there in the middle of the screen.I had to click twice to get it focused.
I changed the position of the text input a bit (up) and it worked. Weird.

Still get the issue here from time to time on an input that is in an ion footer bar that has a keyboard attach