iOS 7 keyboard pushing up tab bar


#1

Is there any way to keep the tab bar at the bottom of the view when pulling up the keyboard on iOS 7? It seems like it’s shrinking the view and pulling the tab bar up. This may be a Cordova issue as I’ve seen some issues with versions >= 3.2 and having to install the Keyboard plugin (which I have had no luck with).

Has anyone else experienced this issues and solved the problem?

You can reproduce this if you start a new Ionic project with ionic-cli. Add a platform for ios and build. Open in Xcode 5 and run on the simulator. Click on the ‘Adopt’ tab and select one of the text boxes.

Please let me know what you find.


Keyboard pushing up tab bar and height=device-height
#2

Got this same thing. Haven’t tried installing the keyboard plugin yet but I will try and let you know. I’ve used JQM before and did have keyboard issues so this may be a ionic issue


#3

Have you already tried setting device-height in the viewport metatag?

<meta name="viewport" content="width=device-width, height=device-height, initial-scale=1, maximum-scale=1, minimal-ui">

#4

@xAlien95 Works like a charm. Thanks for that.


#5

I’ll give the metatag solution a try


#6

@xAlien95, you’re my hero! Thank you!


#7

Tried this trick on Android and no luck, keyboard pushed up as well, even with the viewport meta tag. Any ideas?


#8

@chad_donohue Have you experienced some issue in the viewport? I tried this solution but is breaking the viewport.


#9

Still having tabs go up above the keyboard on android. Still not found anyway to stop that.


#10

Hi Fox, try to add the following setting in your “activity” tag (AndroidManifest.xml):

android:windowSoftInputMode="adjustNothing"

It should give something like

<activity [...] android:windowSoftInputMode="adjustNothing">

It did the trick for me. Even if I would like something more… “gittable” :frowning: (my whole /platforms folder is .gitignored…).