Ionic View App Not Displaying App Shown On PC


#1

When I try to load my app from Ionic View, it just has the “Ionic Blank Starter” default layout despite the fact that I have made numerous changes that show up when I run ‘ionic serve’ on my PC. I have run ‘git push ionic master’ multiple times and it has made no difference. Also, for some reason, this error pops up and I don’t know how to fix it:

npm WARN app@0.0.1 No repository field.
npm WARN app@0.0.1 No license field.

I have been using Ionic for two weeks and am still not entirely sure what I am doing. Any help at all would be greatly appreciated!


#2

Did you commit your changes before pushing them?

What is your ionic info output?


#3

I have it initially committed; I’m not quite sure how to commit it again (unless it’s deploy–which basically sits there and buffers for me).
Ionic info:
[WARN] Error with .\www\lib\ionic\version.json file: FILE_NOT_FOUND, trying .\bower.json.

cli packages: (C:\Users\zenit\AppData\Roaming\npm\node_modules)

@ionic/cli-utils  : 1.18.0
ionic (Ionic CLI) : 3.18.0

global packages:

cordova (Cordova CLI) : 7.1.0
Gulp CLI              : not installed globally

local packages:

Cordova Platforms : android 6.3.0 ios 4.5.3
Ionic Framework   : ionic1 1.3.4

System:

Node : v8.9.1
npm  : 5.5.1
OS   : Windows 10

Environment Variables:

ANDROID_HOME : not set

Misc:

backend : pro

I’m also pretty sure all the ionic stuff is updated


#4

I don’t understand what that means.

Did you commit your new code changes to git before pushing or not?


#5

Sorry–I have not committed the changes, though I tried using 'git commit -m “inital test” ', which ended in

C:\Users\zenit\app>git commit -m "inital test"
On branch master
Changes not staged for commit:
modified: ionic.config.json
modified: package-lock.json
modified: package.json
modified: www/index.html
modified: www/js/app.js

Untracked files:
config.xml
resources/
www/css/ionic.app.css
www/css/ionic.app.min.css

no changes added to commit


#6

Ok, well I managed to get it to commit but something must have gone wrong because now the app (on Ionic View) displays
{{activeProject.title}}
{{task.title}}
Pages
{{task.title}}

The app still works the same on PC, however


#7

Maybe you missed something? Best use a GUI like Sourcetree, Gitkraken or something like that if you are not used to using git on the command line.


#8

Ok I’ll try that. Thanks for the help!