Ionic Upload Error

When I try to upload my ionic app at work I get the following:

Uploading app…
There was an error trying to upload your app.
The address you are trying to reach could not be found.
This could be your internet connection or the server itself is having issues. (CLI v1.3.16)
Your system information:
OS: Mac OS X Mavericks
Node Version: v0.10.28
Cordova CLI: 4.3.0
Ionic CLI Version: 1.3.16
Xcode version: Xcode 6.2 Build version 6C131e
ios-sim version: 3.1.1

I am using CNTLM to access NPM packages and Bower resources. Is there any way to configure the ionic.project to use CNTLM tunneling as well so I can upload and/or login using Ionic CLI at work?

I can upload the app at home fine, it’s just at work I have to deal with proxy issues.

Seems like it was temporary. Maybe the ionic team was doing something with the servers, maybe something else.

Can you try it again ?

Tried again today and got the same error. Basically, I need to know how to add proxy settings to ionic configuration. I think it’s the same issue as this:

I am using the ionic CLI behind a corporate proxy. I have configured CNTLM to allow the use of command line tools. All Ionic commands work as expected except for two; the Ionic upload and ionic package commands both ignore all proxy settings. I have tried the commands on Ionic Beta and on many other versions of the Ionic framework with the same results:

There was an error trying to upload your app.
An error occurred uploading the build: The specific error message: Error: socket
hang up

The specific error message: Error: socket hang up (CLI v2.0.0)

My system information:
Cordova CLI: 6.2.0
Gulp version: CLI version 3.9.1
Gulp local: Local version 3.9.1
Ionic Framework Version: 1.2.4
Ionic CLI Version: 2.0.0
Ionic App Lib Version: 2.0.0-beta.20
OS: Windows 7 SP1
Node Version: v4.4.4

I’ve also tried several GitHub solutions that suggest modifying the following files and using an npm package named https-proxy-agent. I’ve tried every suggested solution in each of the threads with no success.


Has anyone else solved this problem yet?