Ionic serve terminates unexpectedly after upgrade to ionic beta 7


#1

Hello,

We have a weird issue on one of our workstations here. We upgraded our project to ionic beta 7 and other workstations don’t have an issue running ‘ionic serve’

all workstations use
Node CLI: 4.4.2
Ionic CLI: 2.0.0-beta.24
Windows 7

For this specific workstation:
when running ionic serve, the command will terminate after the
"Finished ‘html’ after xxx ms." part and doesn’t show any errors or have any error logs in the project folder.

we tried echo %errorlevel% and it shows -1073741795 so there should be an error as it is not 0.
we tried reinstalling node and ionic but the behavior still persists for this workstation.

Removed sass in the gulpfile.js and the ionic serve command works (except that there is no css as sass task was removed)

Can anyone advise possible cause or how to debug further (make the actual error encountered be shown)?

It may also be worth noting that we tried to install cordova CLI also (afaik, this shouldn’t be needed for ionic serve but tried anyway) but for some reason typing ‘cordova’ will not show anything and %errorlevel% also shows the same error code.

Thanks in advance.


#2

Hello, Please update to the latest version of ionic. With respect cordova try re-installing the cordova again. Please update cordova to 4.2.2


#3

In some cases the problems with SASS on Windows OS are caused by permission issues (it’s strange that you don’t get any error messages though) - that’s why I’ll recommend you to run the Node.js command prompt as Administrator and try again if it’ll work.

PS: And based on the error code you should also check if all updates are installed on this workstation.


#4

Hi,

Your PS link saved the day.
Installing Windows 7 Service Pack 1 solved the issue.

Thanks for the help :slight_smile: