Ionic serve loads localhost:8100 instead of localhost:8100/#/


#1

Hello,

When I run ionic serve at the root of my ionic project, a browser opens to http://localhost:8100/ rather than http://localhost:8100/#/. This causes a white page to be displayed. I have a .otherwise() configured but it has no affect.

When I build the .apk and install it on my device, it also displays a white screen after the splash page. Anyone have ideas on how to solve this?

Thanks a lot for any help provided.

-TrazeK


#2

When I run:

$ionic serve

Running dev server: http://localhost:8100
Ionic server commands, enter:
  restart or r to restart the client app from the root
  goto or g and a url to have the app navigate to the given url
  consolelogs or c to enable/disable console log output
  serverlogs or s to enable/disable server log output
  quit or q to shutdown the server and exit

ionic $

ui-router will redirect to: http://localhost:8100/#/app/welcome as per:

$urlRouterProvider.otherwise('/app/welcome');

Ref: http://robferguson.org/2015/07/19/using-ui-router-for-handling-routes-defining-states-and-sharing-data-between-views/


#3

Right and that’s what I am saying isn’t happening for me. Thanks for your response and I’ll check out the generated starter apps (with ionic start) and see what’s wrong with mine.


#4

Did you ever figure this out? The strange thing for me is that It was loading just fine. Now it’s not. But when deployed on a different computer and built, it adds the # and works fine. Any help?


#5

Hi you guys ever solved this problem?