Ionic serve --lab shows only one platform


#1

I’m working on IONIC 2 project. When I execute ‘ionic serve --lab’, I see chrome just showing only one platform, not cross platform. I’m not sure which platform I’m seeing now but there’s just single platform with full screen.
Any idea to change this to show all platforms?

EDIT

Turns out I’m seeing Android platform. So now I’m working on with android platform only and sometimes test with iOS simulator by ‘ionic run ios’ command. Still found no cause or solution for this issue.


#2

same here but im only able to run ionic serve but not ionic serve --lab…if i run with --lab then error “Cannot GET //__ion-dev-server/ionic_lab.html” will shown…i had update my below is my ionic info

----------------Ionic Info------------------------
Cordova CLI: 6.2.0
Ionic Framework Version: 2.0.0-rc.2
Ionic CLI Version: 2.1.8
Ionic App Lib Version: 2.1.4
Ionic App Scripts Version: 0.0.43
ios-deploy version: Not installed
ios-sim version: Not installed
OS: Windows 10
Node Version: v6.9.1
Xcode version: Not installed


#3

Hello…I have the same problem…any resolution?


#4

in package.json modify to following code
"scripts": {
“build”: “ionic-app-scripts build”,
“watch”: “ionic-app-scripts watch”,
“serve:before”: “watch”,
“emulate:before”: “watch”,
“deploy:before”: “build”,
“build:before”: “build”,
“run:before”: “watch”
},


#5

this worked!! Thanks!


#6

I had a related problem with ionic serve (and ionic serve --lab) not showing anything in the browser but “Transfering data from localhost:8100” for a new blank project (create with ionic start {projectname} blank --v2).
After correcting the package.json file as suggested above it now works fine.
A common error in --v2 project templates?