Ionic serve error code: ELIFECYCLE


#1

Following this steps…

1:

ionic start test --v2

2:

cd test/

3:

ionic serve

I’m, getting this error:

My system information:

Cordova CLI: 6.4.0
Ionic Framework Version: 2.0.0-rc.3
Ionic CLI Version: 2.1.8
Ionic App Lib Version: 2.1.4
Ionic App Scripts Version: 0.0.45
ios-deploy version: 1.8.6
ios-sim version: 5.0.8
OS: macOS Sierra
Node Version: v5.11.1
Xcode version: Xcode 8.1 Build version 8B62

Anyone with this same issue?


Can't serve any Ionic 2 app
#2

I have updated npm and node and the error persists.

I have also tried to downgrade ionic-app-scripts to 0.0.44 version with no luck.

My new system information:

Cordova CLI: 6.4.0
Ionic Framework Version: 2.0.0-rc.3
Ionic CLI Version: 2.1.12
Ionic App Lib Version: 2.1.7
Ionic App Scripts Version: 0.0.44
ios-deploy version: 1.9.0
ios-sim version: 5.0.11
OS: macOS Sierra
Node Version: v7.1.0
Xcode version: Xcode 8.1 Build version 8B62

#3

Solution found :head_bandage: :disappointed_relieved: :