Ionic run --device shows blank screen

I am testing my app on a iPhone (iOS 8.2). When I test with live reload ionic run --device -l it works fine.

I tried to setup timeout but it doesn’t work (I am not sure if that is a recommended practice anyway)

I get the same issue if I try to build and run from Xcode directly.

I have updated cordova etc.

I created a sample sidemenu project to verify. It however is deploying fine.

Since I am not getting any errors, I am not sure where to start looking.

Thank you in advance for any insights.

Discovered the problem. This was more of an exercise in debugging and understanding the difference between testing with livereload vs testing the app untethered.

The problem was a javascript library directory name that was some for reason was not capitalized under root www/lib but capitalized in the platform www/lib.

I am guessing livereload was loading the resources from the root directory and therefore worked correctly whereas in the untethered mode, it was loading it from directory

Since I was not seeing any errors in Xcode, I used Safari’s Develop to access the devices’ browser. On the first load I didn’t see any errors, but by reloading the resources, I saw the error message.

Putting it out here, in case you find yourself stuck with a similar, odd issue.