Blank Screen While running app on emulator or device


#1

My app runs smoothly on web page but when installed on emulator or android device, it appears to be blank.

Please help me out… :sleepy:


#2

I am encountering the same problem, but only on the device (not emulator).

With the latest CLI if I run with livereload it works but not without livereload

The following works for me on the device.

ionic run ios --device -l

If I do the following, I get a blank white screen on launching

ionic run ios --device


#3

I’m having the same issue! I could really use some help on this.
Blank screen when I do ionic run ios, or run the .xcodeproject file
But it works just fine whenever i do ionic run ios -l or ionic serve

Thanks!


#4

Having the same issue, app works with ionic run ios -l, but doesn’t run without it


#5

I had the same problem. Turned out that the directive definitions that I was using had a leading slash in the URL. i.e. instead of

.directive("login", function (){
		return {
		restrict: 'E',
		templateUrl : '/templates/login.html'
	};
});

I needed remove the trailing slash:

.directive("login", function (){
		return {
		restrict: 'E',
		templateUrl : 'templates/login.html'
	};
})

For other people, fixing their src import links solved the problem.

Its odd that the application works with livereload regardless, though.