Ionic run android - configurations not running app on device


#1

I am trying to build and debug ionic 2 app on my android devices. Following are the details of console out put when am trying to run command ionic run android

> #->ionic run android

> ∆ Compiling Sass to CSS
> √ Matching patterns: app/theme/app.+(ios|md).scss

> ∆ Copying fonts
> √ Matching patterns: node_modules/ionic-framework/fonts/**/*.+(ttf|woff|woff2)

> ∆ Copying HTML
> √ Matching patterns: app/**/*.html

> ∆ Compiling and bundling with Webpack...
> √ Using your webpack.config.js file
> √ Sass compilation complete
> √ HTML copied to www/build
> √ Fonts copied to www/build/fonts
> √ Compiling files complete.

> Hash: 3239d7653edd2f88c126
> Version: webpack 1.12.10
> Time: 6745ms
>         Asset     Size  Chunks             Chunk Names
> app.bundle.js  2.68 MB       0  [emitted]  main
>    [0] multi main 64 bytes {0} [built]
>     + 362 hidden modules

> √ Webpack complete

> #->

My app Androidmanifest.xml contains:

 <uses-sdk android:minSdkVersion="16" android:targetSdkVersion="22" />

And when I am running following ** adb devices** command I can see device is attached.

List of devices attached
5b234380 device

Following is the screenshot of packages installed in Android SDK Manager:

Screenshot of Android SDK Manager 1

Screenshot of Android SDK Manager 2

Screenshot of Android SDK Manager 3

Also this is the informations of my ionic system:

> #->ionic info

> Your system information:

> Cordova CLI: 4.3.1
> Ionic Version: 2.0.0-beta.1
> Ionic CLI Version: 2.0.0-beta.17
> Ionic App Lib Version: 2.0.0-beta.8
> ios-deploy version: Not installed
> ios-sim version: Not installed
> OS: Mac OS X El Capitan
> Node Version: v5.3.0
> Xcode version: Not installed


> ******************************************************
>  Dependency warning - for the CLI to run correctly,      
>  it is highly suggested to install/upgrade the following:     

>  Install ios-sim to deploy iOS applications. `npm install -g ios-sim` (may require sudo)
>  Install ios-deploy to deploy iOS applications to devices. `npm install -g ios-deploy` (may require sudo)

> ******************************************************

I just want to run on android device right now, so ios-sim and ios-deploy packages are not installed.

Update When I try to run to add platform android, it saying already exist:

> #->ionic  platform add android
> Running command: /Users/Piccaza/ionic-projects/fobs-v0.9.9/hooks/before_platform_add/init_directories.js /Users/Piccaza/ionic-projects/fobs-v0.9.9
> Platform android already added.

what might be the issue here, so that I am not able to run the app on device? I am kind of stuck for 2 days please help out.


#2

So fire things here. You might want to down grade you version of node to 4x instead.

Also, have you tried running ionic run android --device?


#3

Yes I tried ionic run android --device, but didn’t worked.

Anyway after so many workaround thing started running fine. But now cordova plugins were not working. Like enabling bluetooth and all. which were working fine previously. :frowning: