Ionic resources --splash not working


I think there may be a problem with the splash resource generator.

I could not get ionic resources --splash to work. All I ever was was:

$ ionic resources --splash
Ionic splash screen resources generator
 uploading splash.psd...

I’d placed spash.psd and icon.psd into resources directory, and the dimensions are correct (as specified in The icons created from ionic resources --icon were created absolutely fine.

I finally only got it to work by exporting the psd into a png file.

$ ionic resources --splash
Ionic splash screen resources generator
 uploading splash.png...
splash.png (2208x2208) upload complete
 generating splash ios Default~iphone.png (320x480)...
 generating splash ios Default@2x~iphone.png (640x960)...
 generating splash ios Default-Portrait~ipad.png (768x1024)...
splash ios Default~iphone.png (320x480) generated
 generating splash ios Default-Portrait@2x~ipad.png (1536x2048)...
splash ios Default-Portrait~ipad.png (768x1024) generated
 generating splash ios Default-736h.png (1242x2208)...
splash ios Default@2x~iphone.png (640x960) generated
 generating splash ios Default-667h.png (750x1334)...
splash ios Default-667h.png (750x1334) generated
 generating splash ios Default-568h@2x~iphone.png (640x1136)...
splash ios Default-568h@2x~iphone.png (640x1136) generated
splash ios Default-736h.png (1242x2208) generated
splash ios Default-Portrait@2x~ipad.png (1536x2048) generated

maybe your splash.psd is invalid -> not convertable.

did you changed something or are you using the plain splash.psd-template provided by ionic (i tested it and it works for me)

I’m using png file and I have the same problem with splash generator.

the PSD was not created by me, but by our creative. It is possible that there is something corrupt in the file that causes the issue, but I was able to load the psd into PS 2014 without any issues. However, I just tried again with the psd, after re-saving it from my Photoshop with the same results.

are there multiple layers in the psd file? or try to check the differences between the psd template of ionic and yours.

He’s added 2 layers: grid-lines, then bg, and then logo. Other than that, I cannot see any differences. Should they have been all put on the same layer? Good to know for the future.

yeah try it only with one combined layer

1 Like

Yes, this solved it. Thankyou

I am using a png file and I am still having the same issue.

The reason for your png not being able to upload can’t be the same as my issue with psd files. Have you checked the dimension of the image, see

Same here. I have a splash.png that is a little larger than the minimum. It gets uploaded and there are no errors or warnings. Everything says it worked, but when it’s finished, there are no files in resources/android/splash or resources/ios/splash. Is there a maximum file size limit? When I tried a file I thought might be too large, it didn’t even try to generate the images. It just exited with no message at all.

I think it might be a physical file size issue. I resized my PNG down to 2208x2208. Then I used an image optimizer to get the file size from 8.7MB to 2.6MB, and reran ionic resources -s. That worked. However, 2208x2208 is too small. There are two ios screens larger than that, and they get skipped.

Hi WalkingRiver, do you still have an issue with the images? I didn’t have an issue with the size of the images, so I’d be surprised if that was the problem (unless something has changed at the back-end). Have you made sure that the image dimensions are correct?

Yeah, I had to reduce the file size to get it to work. I haven’t figured out what the limit is, though.

Seems to be a resolution issue, not file size. Any larger than 2208x2208 looks like it works but doesn’t output images. My source file was 40kb and it still failed, but works when I resize it down.

Thanks for that, its working now.

Considering that I used the image from
to get the Splash file which is 2732 x 2732px

Hopefully this can be fixed someday

The same ridiculous issue here. If the splash file is bigger than 2208x2208, nothing is generated (no matter what format). Which is a problem as:

  • The documentation explicitly says that it’s a minimum, plus provides a PSD file which is 2732x2732px
  • 2208x2208 is not big enough:
    splash ios Default-Portrait@~ipadpro.png (2048x2732) skipped, source image splash.png (2208x2208) too small
1 Like

I ran into this issue today as well: Downloaded the 2732x2732 PSD template, added the company logo and saved the file as a PNG. Ran ‘ionic resources -s’ and didn’t get any files or error messages. Resized the file to 2208x2208 per this thread and got the files I needed except for the iPad Pro image. :frowning:

I think this might be an old thread, but I too suffered from this same situation. In my case the console reported all files being created, but they weren’t in the ‘resources/ios/splash’ folder and a system search didn’t find them anywhere else.

I tried numerous things including resizing them to 2208, running the command with --force… nothing seemed to work.

After spending a few hours, I tried
npm install -g ionic

turned out I had an older version, so it needed the update, and walla, it works again.

Thanks to the ionic team for such a brilliant product!! You guys are tops!

1 Like