Ionic Resources service is broken


#1

I am getting Heroku application error page when running ionic resources with the link to “//www.herokucdn.com/error-pages/application-error.html


Error 503: POST https://res.ionic.io/api/v1/upload
Cant Generate Resources With ionic cli
Ionic cordova resources doesn't work
#2

Report it via http://ionicframework.com/support#support please.


#3

I have the same issue. Has yours been resolved yet?


#4

Everyone has this issue currently and several people have reported it to support. We’re just going to have to wait. Sadly until it’s fixed I can’t do any work today.


Ionic cordova resources returns error
#5

I ended up writing ImageMagick script so I don’t depend on the service anymore


#6

@sergeychernyshev Would you mind sharing it?


#7

Would be extremely helpful right now!


#8

It’s working intermittently for me - 80% of the time I’ll get the same error as you, but some times it does run. It often then crashes out with the same error part way through, but by keeping the good files and deleting the 0 bytes files from the splash & icon folders and keeping trying, eventually I managed to get a full set of resources.

Took ages but better than nothing until it’s fixed.


#9

Good to know, I’ll try a couple time :wink:


#10

This is what I have in my Makefile:

resources/android: resources/android/icon resources/android/splash

resources/android/icon:
mkdir -p resources/android/icon/
convert resources/icon.png -resize 36x36 resources/android/icon/drawable-ldpi-icon.png
convert resources/icon.png -resize 48x48 resources/android/icon/drawable-mdpi-icon.png
convert resources/icon.png -resize 72x72 resources/android/icon/drawable-hdpi-icon.png
convert resources/icon.png -resize 96x96 resources/android/icon/drawable-xhdpi-icon.png
convert resources/icon.png -resize 144x144 resources/android/icon/drawable-xxhdpi-icon.png
convert resources/icon.png -resize 192x192 resources/android/icon/drawable-xxxhdpi-icon.png

resources/android/splash:
mkdir -p resources/android/splash/
convert resources/splash.png -resize “320x200^” -gravity center -crop 320x200+0+0 +repage resources/android/splash/drawable-land-ldpi-screen.png
convert resources/splash.png -resize “480x320^” -gravity center -crop 480x320+0+0 +repage resources/android/splash/drawable-land-mdpi-screen.png
convert resources/splash.png -resize “800x480^” -gravity center -crop 800x480+0+0 +repage resources/android/splash/drawable-land-hdpi-screen.png
convert resources/splash.png -resize “1280x720^” -gravity center -crop 1280x720+0+0 +repage resources/android/splash/drawable-land-xhdpi-screen.png
convert resources/splash.png -resize “1600x960^” -gravity center -crop 1600x960+0+0 +repage resources/android/splash/drawable-land-xxhdpi-screen.png
convert resources/splash.png -resize “1920x1280^” -gravity center -crop 1920x1280+0+0 +repage resources/android/splash/drawable-land-xxxhdpi-screen.png
convert resources/splash.png -resize “200x320^” -gravity center -crop 200x320+0+0 +repage resources/android/splash/drawable-port-ldpi-screen.png
convert resources/splash.png -resize “320x480^” -gravity center -crop 320x480+0+0 +repage resources/android/splash/drawable-port-mdpi-screen.png
convert resources/splash.png -resize “480x800^” -gravity center -crop 480x800+0+0 +repage resources/android/splash/drawable-port-hdpi-screen.png
convert resources/splash.png -resize “720x1280^” -gravity center -crop 720x1280+0+0 +repage resources/android/splash/drawable-port-xhdpi-screen.png
convert resources/splash.png -resize “960x1600^” -gravity center -crop 960x1600+0+0 +repage resources/android/splash/drawable-port-xxhdpi-screen.png
convert resources/splash.png -resize “1280x1920^” -gravity center -crop 1280x1920+0+0 +repage resources/android/splash/drawable-port-xxxhdpi-screen.png

UPD: Forum ate my formatting, but it’s just a series of shell commands using ImageMagick’s CLI tools, I will write iOS version next time I build it :wink:


#11

Can y’all try now? We kicked the server


#12

Works perfectly now, thanks! Must’ve been a good kick.


#13

good kick :slight_smile:


#14

What can I say? I’ve played football (soccer) my whole life :soccer:


#15

Orange slices for everyone


#16

Not working again, this is the error I’m getting:

:heavy_multiplication_x: Uploading source images to prepare for transformations - failed!
HTTP Error 400: POST https://res.ionic.io/api/v1/upload

{“Error”:“unable to read uploaded image”,“Width”:0,“Height”:0,“Type”:“png”,“Vector”:false}


#17

sir? can I ask for something a little help?


#18

Fixed it by removing “.png” from the end of the file name.


#19

Hi now i have the same problem , how to fix it.


#20

Problem is back again