'ionic resources' doesn't generate new resources


I’m currently on CLI version 2.0.0-beta.30.

I’ve been trying to generate new icons and splash screens for Android and iOS.
It always used to work excellently but now all of a sudden doesn’t work anymore.

I have a resources folder in my app root with an icon.png and splash.png and android and ios folders in there.
When I run ionic resources or ionic resources --icon or ionic resources --splash it says it will use images from the cache, which it still doesn’t move to the designated resources/android or resources/ios folder. The CLI does however create the resources/{platform}/icon and resources/{platform}/splash folders.
The icon.png and splash.png are both new files so Ionic should not try to fetch the previously generated resources from the cache.

I’ve seen a solution where it was possible to disable the cache using cacheImages: false in resources.js, however this file is no longer available, probably due to updates from Ionic 2. https://github.com/driftyco/ionic-cli/issues/420

What can I do to generate my resources again?

Thanks in advance,


1 Like

I have the same issue with ionic CLI beta 30. @iignatov Have you seen this one before?


By the way, why do I have CLI beta 30 when the latest release say beta 25?

@bryandh Could you open an issue about this? There’s an open issue about ionic resources not working but it’s for CLI v1.7.15. However as far as I can see both the v1 and v2 branches of the CLI are now using ionic-app-lib so there’s a chance that the problem is caused by something related (in which case you can join the discussion in the open issue).

Currently beta.30 is the latest CLI release of the v2 branch. AFAIK the CLI is undergoing a major refactoring so a lot of things are breaking all the time so maybe the releases are more frequent than usual. I guess that because of this the releases info in Github is a bit behind.

try with this
ionic platform rm android
ionic platform add android@latest
ionic resources