Ionic resources android generate res/ folder outside android platform


#1

This is really strange, started to happens after upgrade to rc4 (and latest ionic-cli and cordova).
If i run on console

ionic resources android

the icons and splashscreens are generated inside resources/android

But when i run

ionic platform add android

the res/ folder is placed in the root of my project. The right thing wouldn’t it be copied inside platforms/android?

Ionic info:

Cordova CLI: 6.4.0
Ionic Framework Version: 2.0.0-rc.4
Ionic CLI Version: 2.1.17
Ionic App Lib Version: 2.1.7
Ionic App Scripts Version: 0.0.47
ios-deploy version: Not installed
ios-sim version: Not installed
OS: Linux 4.4
Node Version: v6.4.0
Xcode version: Not installed


#2

There is a known bug at the moment and they are trying to fix it but until then you need to do the work manually by changing the existing icons and screen pngs with the generated once and renaming them to much the old.

once you are done keep a copy of the android res folder for later use "I had to do it twice manually :confused: "

hope it helps


#3

Thanks!

I saw this issue right now, they are saying to try to use

ionic platform add android@latest

I really don’t knwo what @latest means in this case.


#4

you use the command as is @latest is like a key word but remember use

ionic platform remove android first and then
ionic platform add android@latest


#5

I downgrade my cordova to 6.3.1 and… it’s working know.
Found another issue with the same problem.