Android resources not copying properly to platforms folder


#1

This is a new issue that happen with cordova-android 6. After generating the resources using ionic resources command and building the android platform a new folder named res is created at the project root, and newly generated files (icons and splashes) are not being copied to android native platform.

Here is my environmnet information:

Cordova CLI: 6.4.0 
Ionic CLI Version: 2.1.8
Ionic App Lib Version: 2.1.4
ios-deploy version: 1.9.0 
ios-sim version: 3.1.1 
OS: OS X El Capitan
Node Version: v4.2.4
Xcode version: Xcode 7.3.1 Build version 7D1014

Taking in consideration that I don’t want to use older cordova-android versions, which don’t expose the issue.


#2

I have the same problem


#3

same here! any solution or work around?


#4

I have the same problem also ! Ionic 2, latest version here.

Ionic team, is this a known issue ?


#5

This has solved my problem

ionic platform rm android
ionic platform add android@latest

Found it at [SOLVED] Can't update android resources