Ionic push --google-api-key : App not found (CLI v1.6.4)

#1

Hi all,

I’ve followed the ionic.io tutorial to add push notifications into my ionic app.

I’ve got a problem when I add the Google Api Key into ionic.

$ ionic push --google-api-key XXXXXXX...
App not found (CLI v1.6.4)

Your system information:

Cordova CLI: 5.1.1
Gulp version:  CLI version 3.9.0
Gulp local:   Local version 3.9.0
Ionic Version: 1.0.1
Ionic CLI Version: 1.6.4
Ionic App Lib Version: 0.3.8
OS: Distributor ID:    Debian Description:    Debian GNU/Linux 8.1 (jessie) 
Node Version: v0.12.7

The Google Api Key (XXXXXXX…) is valid, I’ve generated it few minutes ago.

Do you have some clues about this problem ?

Thanks

#2

Ionic io init

To update api key into ionic-service-core.

#3

Do you have your app in ionic.io Dashboard?

#4

Yes I have the application well configured in ionic.io dashboard. ID :03780f37

But it is marked as « This app is not live. » and I don’t know why.

Thank you for your support.

#5

Do you see ‘core.js updates with api-key’ or the like if you run ‘ionic io init’?

#6

If you created the app yourself remove the app from dashboard and try to rinitiate the app from CLI wint ‘ionic io init’

#7

OK I’ll try that as soon as possible.

I was following this tutorial step by steps : http://docs.ionic.io/docs/push-from-scratch

#8

The ionic docs are OK. But sometimes it dont work for a lot of repsonse.
My workflow was start with the basic start.
Register a ‘fake’ user. Watch the dashboard for the app. Open the app and watch for user is registrated.
Then install analytics. Very simple. Watch in dashboard for registration of analytics on my app.
To the last I go on with push. Push needs users in your app to register their device ID’s. Before sending push notifications watch for device registration in your user in your app. Watch the log of your app for push registration messages. They should be report OK.

#9

I’ve tried your workflow, but without any success.

So I’ve checked ngCordova pushPlugin, followed this explaination : http://ngcordova.com/docs/plugins/pushNotifications/ and everythings work fine now on Android.

Next step will be to do that for iOS.

So thank you for your support. We can close this topic off.

#10

Have you tried using the command: ionic upload

Let me know if that works.

1 Like