Ionic Pro: View impossible to push


#1

Hello!
I tried to push my app to ionic pro but everytime i got this fatal error:

I added quote to the path in .ssh/config file but it’s the same
I can’t find someone with the same issue so i post this here I hope someone has a solution

The old ionic view worked like a charm so i don’t understand why is it so complicated.

Here is my config :


#2

Ionic Pro is a hosted and closed source service, so there is not much we, the community, can help you with, sorry. Check these:

You can - and should - contact support at http://ionicframework.com/support#support


#3

Thank you i’ll try this :slight_smile:


#4

You can try, in command line, not logged in as administrator,

chown -R $User /Path/To/File

Where $User is the NAME you have in your C:/Users/NAME path

and /Path/To/File is the path to your git config file in your specific project’s git folder.
I think it’s a matter of permissions/file ownership.

Or do the same to your ssh key. It’s one or the other.

If those fail, try actually entering

$User

As opposed to your NAME


#5

Hi,
I tried chown but nothing again :confused:
I don’t know why but the error message changed since the last time, now it says Missing argument
errort
here is the content of my config file :
HostName git.ionicjs.com
IdentityFile "C:\Users\LAROCHEA\.ssh\ionic\883026_rsa"

Sorry for this late answer and thank you


#6

Of course. Could you do me a favor and copy/paste the contents of your git config file? Unless you’re not comfortable doing so. I just want to compare it to one of my functioning ones.

Or, if you have one that’s working, try looking at them side by side. I had a similar issue that I solved by copying a working config file over and changing what needed to be changed as far as details.

Perhaps not the most respected fix, but, a fix